A Go project template
- cookiecutter
- cookiecutter-golang
- golang
- project-template
47,133 repositories indexed
337–360 of 896 · Most stars
A Go project template
From local development to the cloud: web apps development with containers made easy.
A go implementation of the STUN client (RFC 3489 and RFC 5389)
Right imports sorting & code formatting tool (goimports alternative)
Simple, fast and scalable golang rpc library for high load
Golang package for send email. Support keep alive connection, TLS and SSL. Easy for bulk SMTP.
🏎️ Streams & Reactive Programming paradigm for Go: declarative and composable API for event-driven applications
Safe, simple and fast JSON Web Tokens for Go
Find outdated dependencies of your Go projects. go-mod-outdated provides a table view of the go list -u -m -json all command which lists all dependencies of a Go project and their available minor and patch updates. It also provides a way to filter indirect dependencies and dependencies without updates.
Library and tools for working with MP4 files containing video, audio, subtitles, or metadata. The focus is on fragmented files. Includes mp4ff-info, mp4ff-encrypt, mp4ff-decrypt and other tools.
golang long polling library. Makes web pub-sub easy via HTTP long-poll servers and clients :smiley: :coffee: :computer:
Simple, useful and opinionated config loader.
Inter-Blockchain Communication Protocol (IBC) implementation in Golang.
Composable, observable and performant config handling for Go for the distributed processing era
Quick and simple file sharing between different devices, built with Go, React and Typescript.
Golang implemented Redis RDB parser for secondary development and memory analysis
Compute the diff between two JSON documents as a series of JSON Patch (RFC6902) operations
Go implementation of the A* search algorithm
A task scheduler built with Go and Vue.js that allows users to specify recurring jobs via a simple YAML configuration file. The scheduler reads job definitions, executes commands at specified times using cron expressions, and passes in environment variables for each job.
Fast manager for Go-installed binaries in $GOBIN: update, export/import, and migrate toolsets across machines
Demux and mux MPEG Transport Streams (.ts) natively in GO
A self-hosted non-invasive single-binary photo gallery with a focus on speed and simplicity.
Go-Guardian is a golang library that provides a simple, clean, and idiomatic way to create powerful modern API and web authentication.
Instantly jump to your ag or ripgrep matches.