Run SSH and HTTP(S) on the same port
Repository Index
47,133 repositories indexed
97–120 of 275 · Most stars
A reasonably complete and well-tested golang port of httpbin, with zero dependencies outside the go stdlib.
Simple key-value store abstraction and implementations for Go (Redis, Consul, etcd, bbolt, BadgerDB, LevelDB, Memcached, DynamoDB, S3, PostgreSQL, MongoDB, CockroachDB and many more)
- go
- golang
- key-value
- key-value-store
:sparkles: :rocket: EasyTCP is a light-weight TCP framework written in Go (Golang), built with message router. EasyTCP helps you build a TCP server easily fast and less painful.
- tcp
- go
- golang
- middleware
Build platforms that flexibly mix SQL, batch, and stream processing paradigms
- golang
- event-sourcing
- stream-processing
- brokers
htmlquery is golang XPath package for HTML query.
- html
- xpath
- html-parser
- golang
Track AI API quotas across Synthetic, Z.ai, Anthropic (Claude Code), Codex, GitHub Copilot & Antigravity in real time. Lightweight background daemon (<50MB RAM), SQLite storage, Material Design 3 dashboard. Zero telemetry.
- developer-tools
- golang
- quota-tracker
- ai-api-monitoring
Direct file transfer over WebRTC
- webrtc
- file-sharing
- go
- golang
XPath package for golang, supports HTML, XML, JSON document query and more
- xpath
- golang
- xml
- html
Manipulate subtitles in GO (.srt, .ssa/.ass, .stl, .ttml, .vtt (webvtt), teletext, etc.)
- golang-library
- subtitle
- golang
- go
A go implementation of the STUN client (RFC 3489 and RFC 5389)
- stun
- go
- nat-traversal
- rfc-5389
Extract structured data from web sites. Web sites scraping.
- golang
- golang-library
- extract-data
- chrome-fetcher
Find outdated dependencies of your Go projects. go-mod-outdated provides a table view of the go list -u -m -json all command which lists all dependencies of a Go project and their available minor and patch updates. It also provides a way to filter indirect dependencies and dependencies without updates.
- go
- golang
- beautify
- beautifier
The free and privacy respecting pictionary game - Play at https://scribblers.bios-marcel.link
- montagsmaler
- drawing
- guessing-game
- multiplayer
Golang rate limiters for distributed applications
- grpc
- rate-limiting
- token-bucket
- leaky-bucket
Composable, observable and performant config handling for Go for the distributed processing era
- configuration
- config
- state-management
- reloading
Compute the diff between two JSON documents as a series of JSON Patch (RFC6902) operations
- json-patch
- rfc6902
- jsonpatch
- kubernetes-webhook
Instantly jump to your ag or ripgrep matches.
📚 String comparison and edit distance algorithms library, featuring : Levenshtein, LCS, Hamming, Damerau levenshtein (OSA and Adjacent transpositions algorithms), Jaro-Winkler, Cosine, etc...
- go
- golang
- edit-distance
- algorithms
A Go middleware that stores various information about your web application (response time, status code count, etc.)
The open-source, self-hosted video conferencing software. Scalable, customizable, and with a powerful AI Meeting Agent.
- webrtc
- communication
- web-conferencing
- livekit
Parallel and Pipelined HTTP GET Utility
Matching Engine for Limit Order Book in Golang
- exchange
- trading
- orderbook
- execution-engine
A foundational and practical guide for effectively learning and progressively building a blockchain from scratch in Go with gRPC
- blockchain
- blockchain-from-scratch
- concurrent-programming
- cryptography