A tiny WebSocket library for Go.
- go
- websocket
- rfc-6455
- golang
61,121 visible repositories in the index
1–8 of 8 · Most stars
A tiny WebSocket library for Go.
simple, fast, reliable websocket server & client, supports running over tcp/kcp/unix domain socket. keywords: ws, proxy, chat, go, golang...
Push notification server for APNs, FCM and Web Push, written in Go.
📧 Easy to use, yet comprehensive library for sending mails with Go
CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.
Firebase Cloud Messaging for application servers implemented using the Go programming language.
Next-generation HTTP router for Go 1.27+ with type-safe handlers, RFC 9457 errors, and built-in OpenAPI generation. Minimal dependencies, blazing performance.
A tiny, zero-dependency Go library that validates UUIDs against standard RFC 4122 formatting, converts UUIDv7() into timestamps by ensuring accuracy and light compute.