Sign in

Repository Index

47,133 repositories indexed

Filters (1)

Filters

Clear all filters

1–24 of 24 · Most stars

Tiny, Fast, and Deployable anywhere — automate the mundane, unleash your creativity

❤️ 1000+ Hand-Crafted Go Examples, Exercises, and Quizzes. 🚀 Learn Go by fixing 1000+ tiny programs.

A tiny, self-hosted notification inbox for developers. Something happened in one of your apps; Boop tells you on your phone.

CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.

  • cbor
  • rfc-8949
  • cose
  • cwt

A flexible multi-layer Go caching library to deal with in-memory and shared cache by adopting Cache-Aside pattern.

A tiny cross-platform Go library to hide/unhide files and directories

  • fs
  • file
  • hide-files
  • hide-folder

A tiny debug logging tool. Ideal for CLI tools and command applications. Inspired by https://github.com/visionmedia/debug

A tiny, zero-dependency Go library that validates UUIDs against standard RFC 4122 formatting, converts UUIDv7() into timestamps by ensuring accuracy and light compute.

  • go
  • timestamp
  • uuid
  • good-first-issue