A cloud-native Go microservices framework with cli tool for productivity.
Repository Index
47,133 repositories indexed
1–22 of 22 · Most stars
Fast HTTP package for Go. Tuned for high performance. Zero memory allocations in hot paths. Up to 10x faster than net/http
Design-first Go framework that generates API code, documentation, and clients. Define once in an elegant DSL, deploy as HTTP and gRPC services with zero drift between code and docs.
- go
- goa
- microservices
- rest
An actor-based Framework with network transparency for creating event-driven architecture in Golang. Inspired by Erlang. Zero dependencies.
- erlang
- golang
- elixir
- supervisor
Minimalist and zero-dependency scheduling library for Go
- scheduler
- job-scheduler
- quartz
- golang
High performance and extensible micro web framework. Zero memory allocations in hot paths.
- go
- golang
- fasthttp
- micro-framework
CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.
- cbor
- rfc-8949
- cose
- cwt
Marshmallow provides a flexible and performant JSON unmarshalling in Go. It specializes in dealing with unstructured struct - when some fields are known and some aren't, with zero performance overhead nor extra coding needed.
- go
- golang
- json
- performance
A Go library for master-less peer-to-peer autodiscovery and RPC between HTTP services
- service-autodiscovery
- peer-autodiscovery
- zeromq
- golang
:rotating_light: Is a lightweight, fast and extensible zero allocation HTTP router for Go used to create customizable frameworks.
- http-router
- zero-allocation
- customizable-context
Adaptive hedged requests for Go. Cut your p99 latency with zero configuration. Based on Google's "The Tail at Scale" paper.
- concurrency
- go
- golang
- golang-library
MUS format serializer for Go
- golang
- serialization
- codegen
- data-validation
Zero allocation Nullable structures in one library with handy conversion functions, marshallers and unmarshallers
- golang
Simple and scalable boilerplate to build powerful and organized REST projects with Fiber.
- boilerplate
- fiber
- fx
- go
Go module for encoding structs into URL query parameters
- go
- querystring
- form
- form-data
Zero-dependency Go input validation, in-place normalization, and JSON Schema generation from struct tags.
Generate OpenAPI 3.1 specs from Go source code via static analysis — zero annotations, automatic framework detection
Container-focused Golang config: unify Env & Flag parsing in one call with minimal code and zero dependencies.
- cli
- command-line
- config
- configuration
Production-ready Go framework for gRPC + HTTP APIs with MongoDB ODM, zero-config SSL, Temporal workflows, cloud utilities, and bootstrap CLI.
Next-generation HTTP router for Go 1.27+ with type-safe handlers, RFC 9457 errors, and built-in OpenAPI generation. Minimal dependencies, blazing performance.
- generics
- go
- golang
- http-router
A comprehensive, zero-dependency Go SDK for the Paystack API
- api-client
- context-aware
- fintech
- go
Go client for The Colony (thecolony.ai) - AI agent forums, network & identity.
- ai-agents
- colony
- go
- golang