Translated✨ An open-source, free, one-stop Java permission authentication framework that makes authentication and authorization simple and elegant! — Login authentication, permission authentication, distributed Session, microservice gateway authentication, SSO single sign-on, OAuth2.0 unified authentication, jwt integration, API Key authorization, API parameter signing
Translated🏆Gitee's most valuable open source project 🚀:100: A small, comprehensive and elegant open source component for third-party login. It currently supports authorized login via third-party platforms including Github, Gitee, Weibo, DingTalk, Baidu, Coding, Tencent Cloud Developer Platform, OSChina, Alipay, QQ, WeChat, Taobao, Google, Facebook, Douyin, LinkedIn, Xiaomi, Microsoft, Toutiao, Teambition, StackOverflow, Pinterest, Renren, Huawei, WeCom, Kujiale, Gitlab, Meituan, Ele.me, Twitter, Feishu, JD.com, Alibaba Cloud, Ximalaya, Amazon, Slack and Line. Login, so easy!
- justauth
- oauth2
- qqlogin
- googlelogin
A Java 8+ Jar & Android APK Reverse Engineering Suite (Decompiler, Editor, Debugger & More)
- java-decompiler
- apk
- java
- procyon
Open source alternative to Auth0 / Firebase Auth / AWS Cognito
Apereo CAS - Identity & Single Sign On for all earthlings and beyond.
Java JWT: JSON Web Token for Java and Android
Security engine for Java (authentication, authorization, multi frameworks): OpenID Connect, SAML2, CAS, OAuth, LDAP, JWT...
OpenAM is an open-source access management solution for identity authentication, authorization, and federation. It provides single sign-on, adaptive authentication, and centralized policy control, enabling secure access to web, mobile, and cloud applications
Google OAuth Client Library for Java
🔐 An SSL library for configuring http client or server. Rich with features such as hot reloading ssl and trusting additional certificates during runtime, combining multiple keystores, loading pem files and os/jdk certificates, logging certificate information during ssl handshake, bypassing ssl configuration from other libraries and more
OpenDJ is an open-source LDAP directory server written in Java. It provides robust, scalable, and secure directory services for identity management, access control, and authentication in enterprise environments. OpenDJ supports LDAPv3 standard, replication, REST APIs, and high-performance
- ldap-server
- ldap
- opendj
- rest
Generic Capacitor OAuth 2 client plugin. Stop the war in Ukraine!
A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).
The repository host gives no description.
Authentication and authorization providers for Eclipse Vert.x
Security library for Vert.x: OpenID Connect, SAML2, CAS, OAuth, LDAP, JWT...
HOTP/TOTP one time passwords on java phones (J2ME)
- hotp
- j2me
- j2me-platform
- one-time-pad
User management for Play! framework (authentication, registration, password management)
Dropwizard bundle managing authentication through JWT cookies
Easily integrate Facebook authentication into any Play framework application.
JSON Web Token implementation for Java according to RFC 7519. Easily create, parse and validate JSON Web Tokens using a fluent API.
- java
- jwt
- java-jwt
- json-web-token
Shibboleth authentication module for the Play! Framework
Native Shamir Secret Sharing. Securely split & restore secrets on iOS, Android, and Web with a single Capacitor plugin.
Unified Java API for multiple decompilers (Fernflower, Vineflower, Procyon, CFR, JD-Core, JADX)