Open source alternative to Auth0 / Firebase Auth / AWS Cognito
Repository Index
47,133 repositories indexed
1–21 of 21 · Most stars
Apereo CAS - Identity & Single Sign On for all earthlings and beyond.
Java JWT: JSON Web Token for Java and Android
Bastillion gives you a clean, browser-based way to manage SSH access across all your systems—like a bastion host with a friendly dashboard.
Security engine for Java (authentication, authorization, multi frameworks): OpenID Connect, SAML2, CAS, OAuth, LDAP, JWT...
OpenAM is an open-source access management solution for identity authentication, authorization, and federation. It provides single sign-on, adaptive authentication, and centralized policy control, enabling secure access to web, mobile, and cloud applications
🔐 Tutorial of setting up Security for your API with one way authentication with TLS/SSL and mutual authentication for a java based web server and a client with both Spring Boot. Different clients are provided such as Apache HttpClient, OkHttp, Spring RestTemplate, Spring WebFlux WebClient Jetty and Netty, the old and the new JDK HttpClient, the old and the new Jersey Client, Google HttpClient, Unirest, Retrofit, Feign, Methanol, vertx, Scala client Finagle, Featherbed, Dispatch Reboot, AsyncHttpClient, Sttp, Akka, Requests Scala, Http4s Blaze, Kotlin client Fuel, http4k, Kohttp and ktor. Also other server examples are available such as jersey with grizzly. Also gRPC, WebSocket and ElasticSearch examples are included
🔐 An SSL library for configuring http client or server. Rich with features such as hot reloading ssl and trusting additional certificates during runtime, combining multiple keystores, loading pem files and os/jdk certificates, logging certificate information during ssl handshake, bypassing ssl configuration from other libraries and more
OpenDJ is an open-source LDAP directory server written in Java. It provides robust, scalable, and secure directory services for identity management, access control, and authentication in enterprise environments. OpenDJ supports LDAPv3 standard, replication, REST APIs, and high-performance
Generic Capacitor OAuth 2 client plugin. Stop the war in Ukraine!
A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).
Authentication and authorization providers for Eclipse Vert.x
Security library for Vert.x: OpenID Connect, SAML2, CAS, OAuth, LDAP, JWT...
No description provided by the repository host.
OpenIG is an open-source identity gateway (reverse-proxy) that secures, routes, and manages web traffic. It enables authentication, access control, and integration with identity providers, delivering single sign-on and API security for web and cloud applications.
Secure biometric authentication for Capacitor with Face ID, Touch ID, and Android biometrics.
User management for Play! framework (authentication, registration, password management)
Dropwizard bundle managing authentication through JWT cookies
Easily integrate Facebook authentication into any Play framework application.
JSON Web Token implementation for Java according to RFC 7519. Easily create, parse and validate JSON Web Tokens using a fluent API.
Shibboleth authentication module for the Play! Framework