Open Source Identity and Access Management For Modern Applications and Services
- keycloak
- oidc
- saml
47,133 repositories indexed
1–14 of 14 · Most stars
Open Source Identity and Access Management For Modern Applications and Services
Open source alternative to Auth0 / Firebase Auth / AWS Cognito
An OpenID Connect reference implementation in Java on the Spring platform.
Ephemeral root via the CVE-2026-43284 page-cache exploit
OpenAM is an open-source access management solution for identity authentication, authorization, and federation. It provides single sign-on, adaptive authentication, and centralized policy control, enabling secure access to web, mobile, and cloud applications
OpenDJ is an open-source LDAP directory server written in Java. It provides robust, scalable, and secure directory services for identity management, access control, and authentication in enterprise environments. OpenDJ supports LDAPv3 standard, replication, REST APIs, and high-performance
Java cryptographic library that supports Argon2, bcrypt, scrypt and PBKDF2 aimed to protect passwords in databases. Easy to use by design, highly customizable, secure and portable. All the implementations follow the standards and have been reviewed to perform better in the JVM.
Java implementation of Tink
A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).
A Java library that implements a ByteChannel interface over SSLEngine, enabling easy-to-use (socket-like) TLS for Java applications.
User management for Play! framework (authentication, registration, password management)
GraphQL implementation based on light-4j
JSON Web Token implementation for Java according to RFC 7519. Easily create, parse and validate JSON Web Tokens using a fluent API.
Native Shamir Secret Sharing. Securely split & restore secrets on iOS, Android, and Web with a single Capacitor plugin.