Java JWT: JSON Web Token for Java and Android
- jwt
- java
- java-jwt
- jjwt
47,133 repositories indexed
1–19 of 19 · Most stars
Java JWT: JSON Web Token for Java and Android
Android virtual machine and deobfuscator
Modern Java decompiler aiming to be as accurate as possible, with an emphasis on output quality. Fork of the Fernflower decompiler.
An OpenID Connect reference implementation in Java on the Spring platform.
Procyon is a suite of Java metaprogramming tools, including a rich reflection API, a LINQ-inspired expression tree API for runtime code generation, and a Java decompiler.
🔐 A CLI tool to extract server certificates
🔐 An SSL library for configuring http client or server. Rich with features such as hot reloading ssl and trusting additional certificates during runtime, combining multiple keystores, loading pem files and os/jdk certificates, logging certificate information during ssl handshake, bypassing ssl configuration from other libraries and more
Java cryptographic library that supports Argon2, bcrypt, scrypt and PBKDF2 aimed to protect passwords in databases. Easy to use by design, highly customizable, secure and portable. All the implementations follow the standards and have been reviewed to perform better in the JVM.
Java implementation of Tink
A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).
PETEP (PEnetration TEsting Proxy) is an open-source Java application for traffic analysis & modification using TCP/UDP proxies. PETEP is a useful tool for performing penetration tests of applications with various application protocols. ⚡
A Java library that implements a ByteChannel interface over SSLEngine, enabling easy-to-use (socket-like) TLS for Java applications.
Android Secure SharedPreferences Using Facebook Conceal Encryption
HOTP/TOTP one time passwords on java phones (J2ME)
Dropwizard bundle managing authentication through JWT cookies
GraphQL implementation based on light-4j
JSON Web Token implementation for Java according to RFC 7519. Easily create, parse and validate JSON Web Tokens using a fluent API.
Honeypot that mimics Tomcat manager endpoints. Logs requests and saves attacker's WAR file for later study
A J2ME-focused reverse-engineering, decompilation and remapping toolkit, aimed at semantically correct, recompilable output.