Open source alternative to Auth0 / Firebase Auth / AWS Cognito
- authentication
- session-management
- login
- supertokens
47,133 repositories indexed
1–11 of 11 · Most stars
Open source alternative to Auth0 / Firebase Auth / AWS Cognito
OpenDJ is an open-source LDAP directory server written in Java. It provides robust, scalable, and secure directory services for identity management, access control, and authentication in enterprise environments. OpenDJ supports LDAPv3 standard, replication, REST APIs, and high-performance
Java cryptographic library that supports Argon2, bcrypt, scrypt and PBKDF2 aimed to protect passwords in databases. Easy to use by design, highly customizable, secure and portable. All the implementations follow the standards and have been reviewed to perform better in the JVM.
A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).
Nail in the JKS coffin - Cracking passwords of private key entries in a JKS file
HOTP/TOTP one time passwords on java phones (J2ME)
Vuldroid is a Vulnerable Android Application made with security issues in order to demonstrate how they can occur in code
User management for Play! framework (authentication, registration, password management)
Dropwizard bundle managing authentication through JWT cookies
JSON Web Token implementation for Java according to RFC 7519. Easily create, parse and validate JSON Web Tokens using a fluent API.
A Crytpographic Bundle for Dropwizard