Following googlecode project crypto-js, provide standard and secure cryptographic algorithms for NodeJS. Support MD5, SHA-1, SHA-256, RC4, Rabbit, AES, DES, PBKDF2, HMAC, OFB, CFB, CTR, CBC, Base64
Repository Index
61,275 visible repositories in the index
265–288 of 416 · Most stars
Java implementation of Tink
- crypto
- cryptography
- java
- security
Android Malware Sandbox
Slider captcha support mobile
Elliptic curve cryptography functions: Private Key, Public Key, Signature, AES, Encryption, Decryption
Very fast, high-quality hash function, discrete-incremental and streamed hashing-capable (non-cryptographic, header-only C/C++) 27GB/s + PRNG
The JavaScript Crypto Library provides web developers with an extensive and efficient set of cryptographic functions. The library aims to obtain maximum execution speed while preserving modularity and reusability. The library is released as open source under a BDS license.
Generic Capacitor OAuth 2 client plugin. Stop the war in Ukraine!
- capacitor
- oauth2
- oauth2-client
- capacitor-plugin
Bluetooth Honeypot
High-performance pure-javascript SHA1 implementation suitable for large binary data, reaching up to half the native speed.
Simple authorisation addon for Ember apps
- ember
- addon
- authorization
PolyCrypt - A pure JS implementation of the WebCrypto API
Lightweight module to generate Steam-style TOTP auth codes.
Web interface for the Volatility Memory Forensics Framework
Encrypted pastebin using IPFS
A minimal home screen for Samsung Tizen TVs: rotating nature photos, a glass dock of your apps, and a photo website served by the TV.
Sandia Cyber Omni Tracker (SCOT)
- perl
- javascript
- cyber-security
- incident-response
Simulates enough of a Telnet connection in order to log failed login attempts.
A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).
- java
- otp
- totp
- hotp
Code for cracking passwords with neural networks
Self-hosted, invisible CAPTCHA that detects AI agents driving real browsers. GDPR, WCAG 2.2 AA, and EAA: no cookies, no third-party data sharing, and no visual or audio puzzle. With a false-positive budget enforced in CI. Proof of work, drop-in for Turnstile and reCAPTCHA.
- anti-bot
- behavioral-analysis
- bot-detection
- captcha
PETEP (PEnetration TEsting Proxy) is an open-source Java application for traffic analysis & modification using TCP/UDP proxies. PETEP is a useful tool for performing penetration tests of applications with various application protocols. ⚡
- proxy
- tcp
- tcp-proxy
- penetration-testing
JavaScript OAuth 1.0a signature generator (RFC 5849) for node and the browser
Ephemeral root via the CVE-2026-43284 page-cache exploit