A simple, dependency free static file server for Deno with possibly the worst name ever.
- file-server
- deno
- typescript
- live-reload
47,133 repositories indexed
25–43 of 43 · Most stars
A simple, dependency free static file server for Deno with possibly the worst name ever.
Send and receive emails easily, fluently, with one line of code for each operation.
Lightweight, zero-dependency Ruby library for parsing the Accept-Language HTTP header. Implements RFC 4647 Basic Filtering to match user language preferences against available locales. Supports quality values, wildcards, exclusions, prefix matching, and BCP 47 tags.
Go module for encoding structs into URL query parameters
Small, fast, zero-dependency web server for D: HTTP, HTTPS and WebSockets.
Complete, dependency-free Go client for the YNAB API — 44 operations, exact integer money, first-class delta sync, contract-tested. Unofficial.
Zero-dependency Go input validation, in-place normalization, and JSON Schema generation from struct tags.
Fast lossless JSON parse event streaming, in JavaScript.
Configuration and dependency injection
(module) A Go task scheduler for cron jobs with cron expressions, task dependency chains, execution timeouts, and graceful shutdown
Multi-format serialization library for C++17: JSON/JSONC, CSV and MsgPack (dependency-free), plus XML and YAML
Modern, Async, Non-Blocking, zero-dependency C++20 RFC 6455 Compliant WebSocket client & server, cross-platform, single-header, WS/WSS support.
👔 Zero-dependency Crystal shard to validate, generate and format Brazilian burocracias (CPF, CNPJ, CEP)
Typed, zero-dependency CSV parser and encoder for TypeScript. Streams with flat memory and runs on Node, browsers, Deno, Bun, and edge.
Library to Implement Automatic dependency injection by Configuration over Scaned Assemblies
Minimal in-memory deferred task scheduler for Go with ID-based debouncing, cancellation, concurrency limits, and graceful shutdown.
A tiny, zero-dependency Go library that validates UUIDs against standard RFC 4122 formatting, converts UUIDv7() into timestamps by ensuring accuracy and light compute.
Tiny TypeScript functional dependency injection, based on AsyncLocalStorage. Supports Node.js, Deno
Proven and opinionated programming, and configuration model for Java and Vertx based applications. Inspired from ATG Nucleus, provides powerful layer base configuration management using simple properties file.