Sign in

Repository Index

47,133 repositories indexed

Tags: Backend and APIs
Tags

A repository shows when it has any selected Tag.

Clear Tags
Filters

Filters

Clear all filters

25–48 of 65 · Most stars

Translated⚔ Go package for data validation and filtering. support Map, Struct, Form data. A general-purpose Go library for data validation and filtering, simple to use, with most commonly used validators and filters built in, and support for custom validators, custom messages, and field translation.

  • validation
  • validator
  • filter
  • govalidator

CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.

  • cbor
  • rfc-8949
  • cose
  • cwt

PipelinR is a lightweight command processing pipeline ❍ ⇢ ❍ ⇢ ❍ for your Java awesome app.

  • java
  • architecture
  • service-layer
  • pipes-and-filters

Fast and Easy mapping from database and csv to POJO. A java micro ORM, lightweight alternative to iBatis and Hibernate. Fast Csv Parser and Csv Mapper

Glue - Robust Go and Javascript Socket Library (Alternative to Socket.io)

A simple server for push notifications via Matrix (and a minimalistic alternative to Pushover and Gotify) 🚀📯

  • push-notifications
  • gotify
  • matrix-org
  • notifications

Lightweight Dart web server. Features: request routing, filtering, template engine, WebSocket, MVC design pattern, and file-based static resources.

RAFCON (RMC advanced flow control) uses hierarchical state machines, featuring concurrent state execution, to represent robot programs. It ships with a graphical user interface supporting the creation of state machines and contains IDE like debugging mechanisms. Alternatively, state machines can programmatically be generated using RAFCON's API.

  • robotics
  • graphical-programming
  • state-machine

Open-source event management, ticketing and membership platform for communities, clubs, independent venues and independent artists.

  • django
  • django-ninja
  • eu-vat
  • event-management

Lightweight, zero-dependency Ruby library for parsing the Accept-Language HTTP header. Implements RFC 4647 Basic Filtering to match user language preferences against available locales. Supports quality values, wildcards, exclusions, prefix matching, and BCP 47 tags.

  • http
  • accept-language-parser
  • accept-language

The power you need to cleanse, filter, sort, reshape, manage and analyze data from CSV files.

  • csv-parser
  • csv-reader
  • csv-writer
  • utf-8