🌏 A zero-dependency networking solution for building modern and secure iOS, watchOS, macOS and tvOS applications.
- networking
- library
- cocoapods
- swift
47,133 repositories indexed
25–48 of 49 · Most stars
🌏 A zero-dependency networking solution for building modern and secure iOS, watchOS, macOS and tvOS applications.
Lightweight, zero-dependency Ruby library for parsing the Accept-Language HTTP header. Implements RFC 4647 Basic Filtering to match user language preferences against available locales. Supports quality values, wildcards, exclusions, prefix matching, and BCP 47 tags.
Go module for encoding structs into URL query parameters
Routing library for the Scala platform
Small, fast, zero-dependency web server for D: HTTP, HTTPS and WebSockets.
Lightweight, zero-dependency, and extendable library for comperhensive configuration management
⚡️ Zero-dependency QR Code generator and decoder for Go
Zero-dependency Go input validation, in-place normalization, and JSON Schema generation from struct tags.
Zero-dependency 128-bit fixed-point decimal for Go. Exact SQL NUMERIC / PostgreSQL semantics, no heap allocation, no panics — built for money, ledgers and banking arithmetic.
Fast lossless JSON parse event streaming, in JavaScript.
A lightweight, zero-dependency TUI dashboard for managing Docker containers and images dynamically in the terminal.
Fast, zero-dependency cost calculator and customizable statusline for Claude Code. Single binary, no runtime needed.
Modern, Async, Non-Blocking, zero-dependency C++20 RFC 6455 Compliant WebSocket client & server, cross-platform, single-header, WS/WSS support.
Statically compiled, zero-dependency Git pre-commit secret scanner and credentials detector written in Go. An alternative to Gitleaks and git-secrets.
A powerful zero-dependency json logger.
👔 Zero-dependency Crystal shard to validate, generate and format Brazilian burocracias (CPF, CNPJ, CEP)
A High Performance, Generic, thread-safe, zero-dependency, key-value, in-memory cache
Simple leveled logging wrapper around standard log package
Typed, zero-dependency CSV parser and encoder for TypeScript. Streams with flat memory and runs on Node, browsers, Deno, Bun, and edge.
FlashFlags is an ultra-fast, zero-dependency, lock-free command-line flag parsing library for Go. Originally built for Argus, it provides great performance while maintaining simplicity and ease of use.
Zero-dependency Go implementation of the Unix getopt function, tested against GNU libc.
Minimal in-memory deferred task scheduler for Go with ID-based debouncing, cancellation, concurrency limits, and graceful shutdown.
A tiny, zero-dependency Go library that validates UUIDs against standard RFC 4122 formatting, converts UUIDv7() into timestamps by ensuring accuracy and light compute.
Zero-dependency drop-in context.Context replacement for graceful shutdown