A TypeScript RPC framework, with runtime type checking and serialization, support both HTTP and WebSocket. It is very suitable for website / APP / games, and absolutely comfortable to full-stack TypeScript developers.
Repository Index
84,085 visible repositories in the index
49–72 of 97 · Most stars
Full-featured Node.js framework 🚀
- typescript
- framework
- dependency-injection
- api
Ninja is a full stack web framework for Java. Rock solid, fast and super productive.
- java
- webframework
- restful
- ninja
Rust Fullstack Framework
- rust
- fullstack
- framework
- wasm
The fastest Python web framework, built on Django. Rust (Actix Web) HTTP server + async typed handlers + msgspec, with the full Django ORM, Admin, middleware and auth. 300k+ req/s, no gunicorn/uvicorn.
A robust Punycode converter that fully complies to RFC 3492 and RFC 5891.
Protocol Buffers for ECMAScript. The only JavaScript Protobuf library that is fully-compliant with Protobuf conformance tests.
- protobuf
- protocol-buffers
- javascript
- protoc-plugin
Unlocking the Full Potential of OPC UA with Typescript and NodeJS - http://node-opcua.github.io/
- iot-platform
- opc-ua
- node-opcua
- nodejs
Rapidoid - Extremely Fast, Simple and Powerful Java Web Framework and HTTP Server!
- rapidoid
- java
- webframework
- restful
Boilerplate to build a full stack web application using React, Node.js, Express and Webpack.
Faygo is a fast and concise Go Web framework that can be used to develop high-performance web app(especially API) with fewer codes. Just define a struct handler, faygo will automatically bind/verify the request parameters and generate the online API doc.
- web-framework
- http2
- golang
- server
Full-stack Elixir web framework that runs your Elixir code in the browser
- beam
- components
- elixir
- erlang
Angular Full Stack project built using Angular, Express, Mongoose and Node. Whole stack in TypeScript.
Strongly typed, full-featured, light, versatile yet powerful Twitter API v1.1 and v2 client for Node.js.
- twitter-api
- npm-package
- streaming-api
A simple, blazing-fast CSV parser and encoder. Full RFC 4180 compliance.
Fullstack SaaS Boilerplate built with tRPC, Fastify and React
Fullstack GraphQL Framework for TypeScript
- graphql
- schema-builder
- typescript
- trpc
Add Social Reactions to Laravel Eloquent Models. It lets people express how they feel about the content. Fully customizable Weighted Reaction System & Reaction Type System with Like, Dislike and any other custom emotion types. Do you react?
- laravel
- eloquent
- cog
- like
the 5k pocket full-of-gags web microframework
:point_up::running: Modern Relay Starter Kit - Integrated with Relay, GraphQL, Express, ES6/ES7, JSX, Webpack, Babel, Material Design Lite, and PostCSS
Textacular exposes full text search capabilities from PostgreSQL, and allows you to declare full text indexes. Textacular will extend ActiveRecord with named_scope methods making searching easy and fun!
- activerecord
- postgresql
- rails
- ruby
:steam_locomotive: Decodes url.Values into Go value(s) and Encodes Go value(s) into url.Values. Dual Array and Full map support.
- decoding
- encoder
- form
- parser
libopenapi is a fully featured, high performance OpenAPI 3.2, 3.1, 3.0, Overlays and Arazzo parser, library, validator and toolkit for go applications.
- go
- golang
- openapi
- openapi-spec
A powerful Clojure web library, full HTTP, full async - see https://juxt.pro/yada/index.html
- clojure
- swagger
- bidi
- manifold