BadActor.org An in-memory application driven jailer written in Go
Repository Index
47,133 repositories indexed
169–192 of 329 · Most stars
Respounder detects presence of responder in the network.
- responder
- golang
- network-security-monitoring
- network-security
A production-ready SaaS template built with Next.js 15, Supabase, and Tailwind CSS. Includes authentication, user management, file storage, task management demos, and secure RLS policies. Now with a complete React Native + Expo mobile app template! Easily customizable with pre-built themes, i18n support (EN/PL/ZH), and legal documents.
The universe in numbers. Free, open-source calculators for everything countable.
The most comprehensive Hack The Box writeup collection - 500+ machines, 400+ challenges, interactive knowledge graph, skill trees, attack path diagrams, ProLabs, Sherlocks, OSCP/CPTS/CRTO prep. Browse: momenbasel.github.io/htb-writeups
- active-directory
- cheatsheet
- ctf
- cybersecurity
🚀AutoRuns is a PowerShell module that will help do live incident response and enumerate autoruns artifacts that may be used by legitimate programs as well as malware to achieve persistence.
Universal web application security sensor intended for real-time monitoring and defense.
inVtero.net: A high speed (Gbps) Forensics, Memory integrity & assurance. Includes offensive & defensive memory capabilities. Find/Extract processes, hypervisors (including nested) in memory dumps using microarchitechture independent Virtual Machiene Introspection techniques
- forensics
- hypervisor
- memory-dump
- reverse-engineering
Very fast, high-quality hash function, discrete-incremental and streamed hashing-capable (non-cryptographic, header-only C/C++) 27GB/s + PRNG
Cryptographic library for Embarcadero Delphi and potentially for FPC as well
- delphi
- key-deviation-algorithms
- cryptographic-checksums
- kdf1
Inspektor is a protocol-aware proxy that is used to enforce access policies👮
- security
- openpolicyagent
- acl
- rust
Pakkero is a binary packer written in Go made for fun and educational purpose. Its main goal is to take in input a program file (elf binary, script, even appimage) and compress it, protect it from tampering and intrusion.
- launcher
- payload
- elf
- elf-binaries
Generic Capacitor OAuth 2 client plugin. Stop the war in Ukraine!
- capacitor
- oauth2
- oauth2-client
- capacitor-plugin
Autonomous OODA-loop pentesting agent. Hermes brain, Kali + Playwright tools over MCP, ATT&CK as the Orient language.
- ai-agents
- autonomous-agents
- kali-linux
- llm-agents
Lightweight module to generate Steam-style TOTP auth codes.
Create adversarial attacks against machine learning Windows malware detectors
- adversarial-machine-learning
- infosec
- python
- attack
A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).
- java
- otp
- totp
- hotp
POT is an Erlang library for generating Google Authenticator compatible one time passwords
- erlang
- 2fa
- authenticator
- elixir
:elephant: :busts_in_silhouette: Manage PostgreSQL roles and privileges from YAML or LDAP
- ldap
- postgresql
- yaml
- roles
Self-hosted, invisible CAPTCHA that detects AI agents driving real browsers. GDPR, WCAG 2.2 AA, and EAA: no cookies, no third-party data sharing, and no visual or audio puzzle. With a false-positive budget enforced in CI. Proof of work, drop-in for Turnstile and reCAPTCHA.
- anti-bot
- behavioral-analysis
- bot-detection
- captcha
JavaScript OAuth 1.0a signature generator (RFC 5849) for node and the browser
'Packet Capture Forensic Evidence eXtractor' is a tool that finds and extracts files from packet capture files
Secure shell history commands by finding sensitive data
Open Source SIEM (Security Information and Event Management system).
- siem
- risk-management
- risk-assessment
- vulnerability-management