JSON for Modern C++
- json
- json-pointer
- json-patch
- cbor
47,133 repositories indexed
1–12 of 12 · Most stars
JSON for Modern C++
Extremely fast, in memory, serialization, reflection, and RPC library for C++. JSON, BEVE, BSON, CBOR, CSV, JSONB, MessagePack, TOML, YAML, EETF
A C++20 library for fast serialization, deserialization and validation using reflection. Supports JSON, Avro, Boost Serialization, BSON, Cap'n Proto, CBOR, Cereal, Command line interfaces, CSV, Environment variables, flexbuffers, msgpack, parquet, TOML, UBJSON, XML, YAML, yas / msgpack.org[C++20]
idiomatic codec and rpc lib for msgpack, cbor, json, etc. msgpack.org[Go]
TreeFrog Framework : High-speed C++ MVC Framework for Web Application
CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.
A C++, header-only library for constructing JSON and JSON-like data formats, with JSON Pointer, JSON Patch, JSON Schema, JSONPath, JMESPath, CSV, MessagePack, CBOR, BSON, UBJSON, toon-format
C++ header-only JSON library
This Delphi code library lets you model structured data and serialize to/from : CBOR, JSON, MessagePack msgpack.org[Delphi], ION, UBJSON, BSON, Smile, DataObj, etc.
Easy CBOR encoding and decoding for iOS, macOS, tvOS and watchOS.
OCaml CBOR generic decoder/encoder, RFC 7049, http://cbor.io/
Lightweight implementation of cbor for Micropython