A lightweight library for converting complex objects to and from simple Python datatypes.
Repository Index
47,133 repositories indexed
1–11 of 11 · Most stars
Static reflection for enums (to string, from string, iteration) for modern C++, work with any enum type without any macro or boilerplate code
CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.
Scala macros for compile-time generation of safe and ultra-fast JSON codecs + circe booster
binary serialization format
A tool for fast serializing & deserializing of JSON
A declarative serialization framework for controlling formatting of data at the byte and bit level using field bindings, converters, and code.
A correct and safe(er) JSON RFC 8259 reader/writer with sane defaults.
MUS format serializer for Go
An Fast, Intuitive and Type-Safe C++ Enumeration Support Library
edn (extensible data notation) encoder/decoder for Elixir