Simple Binary Encoding (SBE) - High Performance Message Codec
- codec
- java
- c-plus-plus
- golang
47,133 repositories indexed
1–7 of 7 · Most stars
Simple Binary Encoding (SBE) - High Performance Message Codec
idiomatic codec and rpc lib for msgpack, cbor, json, etc. msgpack.org[Go]
CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.
Scala macros for compile-time generation of safe and ultra-fast JSON codecs + circe booster
Header-only C++11 library to encode/decode base64, base64url, base32, base32hex and hex (a.k.a. base16) as specified in RFC 4648, plus Crockford's base32. MIT licensed with consistent, flexible API.
Substrate RPC client for go aka GSRPC
vertx-values enhances JSON handling in Vert.x by providing codecs for the immutable JSON objects from the json-values library. It eliminates the need for copying JSON data during transmission over the Event Bus, reducing garbage collection overhead and boosting performance.