CTF framework and exploit development library
Repository Index
61,121 visible repositories in the index
1–24 of 32 · Most stars
Let's Encrypt/ACME client and library written in Go
- letsencrypt
- acme
- certificate
- tls
Predatory ESP32 Firmware
- bruce
- cardputer
- esp32-s3
- hardware
Iceman Fork - Proxmark3
- nfc
- rfid
- mifare
- proxmark3
Go package for UUIDs based on RFC 4122 and DCE 1.1: Authentication and Security Services.
- go
- uuid
An ACME-based certificate authority, written in Go.
- boulder
- go
- acme
- certificate-authority
🕵️♂️ (2-in-1) Email & Username OSINT suite featuring native MCP support for deep data extraction just from a single Email/Username. Analyzes 2720+ actively maintained scan vectors (210+ email / 2510+ username) for security research, investigations, and digital footprinting.
- osint
- osint-tool
- python
- osint-tools
DNS over HTTPS config profiles for iOS & macOS
A portable device that can spoof/emulate any magnetic stripe, credit card or hotel card "wirelessly", even on standard magstripe (non-NFC/RFID) readers. It can disable Chip&PIN and predict AMEX card numbers with 100% accuracy.
Unicorn is a simple tool for using a PowerShell downgrade attack and inject shellcode straight into memory. Based on Matthew Graeber's powershell attacks and the powershell bypass technique presented by David Kennedy (TrustedSec) and Josh Kelly at Defcon 18.
A ruby implementation of the RFC 7519 OAuth JSON Web Token (JWT) standard.
- jwt
- ruby-jwt
- oauth-json-web
- ruby
Entity Framework Core Power Tools - reverse engineering, migrations and model visualization in Visual Studio & CLI
- entity-framework-core
- visual-studio
- entity-framework
- model-visualization
The repository host gives no description.
- defcon
- android
- blackhat
- blackbox
Android Unpacker presented at Defcon 22: Android Hacker Protection Level 0
- android-unpacker
- gdb
- qemu
- reverse-engineering
Fastest 5KB JS implementation of secp256k1 signatures and ECDH
- secp256k1
- ecdsa
- ecc
- cryptography
A mostly-serverless distributed hash cracking platform
Fastest 5KB JS implementation of ed25519 signatures
- ed25519
- curve25519
- eddsa
- cryptography
Audited & minimal JS implementation of Salsa20, ChaCha and AES
- aes-siv
- chacha20
- chacha20-poly1305
- chacha20poly1305
Sweeping in the cracks
A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).
- java
- otp
- totp
- hotp
Self-hosted, invisible CAPTCHA that detects AI agents driving real browsers. GDPR, WCAG 2.2 AA, and EAA: no cookies, no third-party data sharing, and no visual or audio puzzle. With a false-positive budget enforced in CI. Proof of work, drop-in for Turnstile and reCAPTCHA.
- anti-bot
- behavioral-analysis
- bot-detection
- captcha
JavaScript OAuth 1.0a signature generator (RFC 5849) for node and the browser
An Elixir implementation of the JSON Web Token (JWT) Standard, RFC 7519
Simple ELF crypter. Uses RC4 encryption.