Sign in

Repository Index

47,133 repositories indexed

Tag: Backend and APIs
Tag
Filters

Filters

Clear all filters

1–24 of 56 · Most stars

Fast HTTP package for Go. Tuned for high performance. Zero memory allocations in hot paths. Up to 10x faster than net/http

🌱Light and powerful C++ web framework for highly scalable and resource-efficient web application. It's zero-dependency and easy-portable.

  • c-plus-plus
  • webframework
  • webserver
  • zero-dependency

Design-first Go framework that generates API code, documentation, and clients. Define once in an elegant DSL, deploy as HTTP and gRPC services with zero drift between code and docs.

An actor-based Framework with network transparency for creating event-driven architecture in Golang. Inspired by Erlang. Zero dependencies.

  • erlang
  • golang
  • elixir
  • supervisor

A blazingly fast multi-language serialization framework for idiomatic domain objects, schema IDL, and cross-language data exchange.

  • cross-language
  • fast
  • jit
  • multiple-language

Near-zero config .NET library that makes advanced application features like Task Scheduling, Caching, Queuing, Event Broadcasting, and more a breeze!

Cista is a simple, high-performance, zero-copy C++ serialization & reflection library.

  • serialization
  • cpp
  • cpp17
  • reflection

Eclipse iceoryx™ - true zero-copy inter-process-communication

  • iceoryx
  • eclipse
  • ipc
  • inter-process-communication

One of the World's Fastest .NET CSV Parsers. Modern, minimal, fast, zero allocation, reading and writing of separated values (`csv`, `tsv` etc.). Cross-platform, trimmable and AOT/NativeAOT compatible with blazing fast SIMD vectorized parsing.

  • csharp
  • csv
  • csv-parser
  • csv-reader

Zero-boilerplate REST API framework for PHP 8+. Auto-generates routes, docs, validation.

  • restler
  • php
  • phpdoc-comments
  • html-format

High performance and extensible micro web framework. Zero memory allocations in hot paths.

  • go
  • golang
  • fasthttp
  • micro-framework

CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.

  • cbor
  • rfc-8949
  • cose
  • cwt

Microserver is a Java 8 native, zero configuration, standards based, battle hardened library to run Java Rest Microservices via a standard Java main class. Supporting pure Microservice or Micro-monolith styles.

Fast, lightweight, and RFC 4180 compliant CSV library for Java. Zero dependencies, ~90 KiB. Trusted by Apache NiFi, JUnit, and Neo4j.

  • csv
  • java
  • csv-parser
  • csv-reader

ClamAV antivirus scanning for Node.js — scan file uploads with a single function call. Zero dependencies. Typed Symbol verdicts. Local or Docker/clamd.