🌱Light and powerful C++ web framework for highly scalable and resource-efficient web application. It's zero-dependency and easy-portable.
- c-plus-plus
- webframework
- webserver
- zero-dependency
47,133 repositories indexed
1–11 of 11 · Most stars
🌱Light and powerful C++ web framework for highly scalable and resource-efficient web application. It's zero-dependency and easy-portable.
Minimalist and zero-dependency scheduling library for Go
Coherent, zero-dependency, lazy, simple, GraphQL over WebSocket Protocol compliant server and client.
Fast, lightweight, and RFC 4180 compliant CSV library for Java. Zero dependencies, ~90 KiB. Trusted by Apache NiFi, JUnit, and Neo4j.
Lightweight, zero-dependency Ruby library for parsing the Accept-Language HTTP header. Implements RFC 4647 Basic Filtering to match user language preferences against available locales. Supports quality values, wildcards, exclusions, prefix matching, and BCP 47 tags.
Small, fast, zero-dependency web server for D: HTTP, HTTPS and WebSockets.
Zero-dependency Go input validation, in-place normalization, and JSON Schema generation from struct tags.
Fast lossless JSON parse event streaming, in JavaScript.
Modern, Async, Non-Blocking, zero-dependency C++20 RFC 6455 Compliant WebSocket client & server, cross-platform, single-header, WS/WSS support.
Typed, zero-dependency CSV parser and encoder for TypeScript. Streams with flat memory and runs on Node, browsers, Deno, Bun, and edge.
A comprehensive, zero-dependency Go SDK for the Paystack API