1501.darklynx / request-baskets
HTTP requests collector to test webhooks, notifications, REST clients and more ...
- webhooks
- test-automation
- qa
- testing
- http-requests
- rest
- +3 more
Ranked by Attention Score: stars gained over the last 180 complete days
1501–1600 of 2,174 by Attention Score · May 9, 2026 – Nov 4, 2026 (UTC)
HTTP requests collector to test webhooks, notifications, REST clients and more ...
Server that accepts metrics via the Graphite protocol and exports them as Prometheus metrics
🍄📑 Filesystem and git-based wiki engine for the independent web written in Go and using Mycomarkup as its primary markup language.
Simple and fast webp library for golang
Jest-like snapshot testing in Go 📸
A tool for formatting Go test results as readable documentation
Lightweight library for the transactional outbox pattern in Go, not tied to any specific relational database or broker.
pocketbase boilerplate
Zero-dependency 128-bit fixed-point decimal for Go. Exact SQL NUMERIC / PostgreSQL semantics, no heap allocation, no panics — built for money, ledgers and banking arithmetic.
Go validation library with functional API built on top of generics, statically typed and batteries included :fire:
Go dependency management tool experiment (deprecated)
Service registry bridge for Docker with pluggable adapters
The interactive web server
Generate a modern Web project with Go and Angular, React, or Vue in seconds 🎲
Gota: DataFrames and data wrangling in Go (Golang)
A Golang tool that does static analysis, unit testing, code review and generate code quality report.
Go package for reading from continously updated files (tail -f)
rtop is an interactive, remote system monitoring tool based on SSH
Sonic is a blogging platform developed by Go. Simple and powerful
manage your git repositories in one place
High-performance, columnar, in-memory store with bitmap indexing in Go
Chanify is a safe and simple notification tools. This repository is command line tools for Chanify.
Plugin-driven, extensible HTTP client toolkit for Go
Terratag is a CLI tool that enables users of Terraform to automatically create and maintain tags across their entire set of AWS, Azure, and GCP resources
Your AI powered terminal assistant.
⭕ A *nix cross-platform (OS agnostic) supervisor
Build platforms that flexibly mix SQL, batch, and stream processing paradigms
Powerful mock generation tool for Go programming language
:robot: task runner for local and remote hosts
A go implementation of the STUN client (RFC 3489 and RFC 5389)
Quick and simple file sharing between different devices, built with Go, React and Typescript.
TUI tool to manage your docker images, containers and volumes 🚀
Compute the diff between two JSON documents as a series of JSON Patch (RFC6902) operations
Flexible E-Commerce Framework on top of Flamingo. Used to build E-Commerce "Portals" and connect it with the help of individual Adapters to other services.
Simple to use, simple to deploy, one time self destruct messaging service, with hashicorp vault as a backend
A tool for tuning TimescaleDB for better performance by adjusting settings to match your system's CPU and memory resources.
Substation is a toolkit for routing, normalizing, and enriching security event and audit logs.
🐸 Effortless persistent SSH tunnels with embedded server for seamless connectivity
dht is used by anacrolix/torrent, and is intended for use as a library in other projects both torrent related and otherwise
Passive DNS Capture and Monitoring Toolkit
database gateway for building data-driven applications
The repository host gives no description.
🚨 slog: Attribute formatting
Inline styling for html mail in golang
This is a Golang wrapper for working with TMDb API. It aims to support version 3.
Type-safe, persistent, embedded task queues and background job runner w/ SQLite. Web monitoring UI included.
CetusGuard is a tool that protects the Docker daemon socket by filtering calls to its API endpoints.
LazyVPN is an Omarchy VPN manager for WireGuard connections. It replaces manual systemd-networkd configuration with a fast, keyboard-driven TUI featuring killswitch, auto-recovery, and Waybar integration.
This SDK has reached end-of-support. The AWS SDK for Go v2 is available here: https://github.com/aws/aws-sdk-go-v2
An in-memory cache library for golang. It supports multiple eviction policies: LRU, LFU, ARC
Multi-platform Nintendo Game Boy Color emulator written in Go
Concurrency-safe Go caching library with expiration capabilities and access counters
Engo is an open-source 2D game engine written in Go.
A natural language date/time parser with pluggable rules
Derives and generates mundane golang functions that you do not want to maintain yourself
Golang commandline wrapper for wkhtmltopdf
File system event notification library on steroids.
Expression evaluation in golang
:gem: Modern ORM for Golang - Testable, Extendable and Crafted Into a Clean and Elegant API
Zero-config, pure-Go HTTP request visualizer & debugger for local Go web development.
A Go (golang) package that enhances the standard database/sql package by providing powerful data retrieval methods as well as DB-agnostic query building capabilities.
Pure golang package for reading and writing xz-compressed files
This repo maintains DM (a data migration platform) and TiCDC (change data capture for TiDB)
pganalyze statistics collector for gathering PostgreSQL metrics and log data
Open source Terraform module registry with UI, optional Git integration and deep analysis. Demo: https://terrareg-main.gitlab-pr.dockstudios.co.uk
Package tasks is an easy to use in-process scheduler for recurring tasks in Go
SurrealDB SDK for Golang
TranslatedPacket monster (っ‘-’)╮=͟͟͞͞◒ ヽ( '-'ヽ) TUI tool for sending packets of arbitrary input and monitoring packets on any network interfaces (default: eth0). Windows/macOS/Linux
The Next-Generation Webhooks Gateway.
Golang wrapper for Exiftool : extract as much metadata as possible (EXIF, ...) from files (pictures, pdf, office documents, ...)
Pakkero is a binary packer written in Go made for fun and educational purpose. Its main goal is to take in input a program file (elf binary, script, even appimage) and compress it, protect it from tampering and intrusion.
PostgreSQL server wire protocol. Build your own server and start serving connections.
Pocketbase extention built in Go with stripe webhooks currently in use at sign365.com.au and fastpocket.dev
The repository host gives no description.
An application platform for your personal web services. https://dropserver.org
The production agent framework for Go — type-safe agents, structured output, multi-provider streaming, guardrails, and multi-agent orchestration with zero core dependencies.
Next-generation HTTP router for Go 1.27+ with type-safe handlers, RFC 9457 errors, and built-in OpenAPI generation. Minimal dependencies, blazing performance.
⚓ Terminal UI (TUI) for Docker Compose — manage containers, view logs, exec, monitor CPU/RAM.
For parsing, creating and editing unknown or dynamic JSON in Go