701.EsotericSoftware / reflectasm
High performance Java reflection
Ranked by Attention Score: stars gained over the last 30 complete days
701–800 of 1,058 by Attention Score · Oct 5, 2026 – Nov 3, 2026 (UTC)
High performance Java reflection
An OpenID Connect reference implementation in Java on the Spring platform.
Community WebView Plugin - Allows Flutter to communicate with a native WebView.
Custom Tabs with Material Design effects
An Extensible Request/Response Workbench
Simple API, Complex Emails (Jakarta Mail smtp wrapper)
A sampling JVM profiler without the safepoint sample bias
SirixDB is an an embeddable, bitemporal, append-only database system and event store, storing immutable lightweight snapshots. It keeps the full history of each resource. Every commit stores a space-efficient snapshot through structural sharing. It is log-structured and never overwrites data. SirixDB uses a novel page-level versioning approach.
Make Slack and Facebook Bots in Java.
轻量级DDD正向/逆向业务建模框架,支撑复杂业务系统的架构演化!
Twitter's collection of LZO and Protocol Buffer-related Hadoop, Pig, Hive, and HBase code.
HiveMQ MQTT Client is an MQTT 5.0 and MQTT 3.1.1 compatible and feature-rich high-performance Java client library with different API flavours and backpressure support
A Fast Scroller for the RecyclerView world!
Spring HATEOAS - Library to support implementing representations for hyper-text driven REST web services.
A nicer-looking, more intuitive and highly customizable alternative for radio buttons and dropdowns for Android.
Android AlertDialog with moving dots progress indicator
An Android library containing a simple TableView and an advanced SortableTableView providing a lot of customisation possibilities to fit all needs.
A tool for running android and iOS appium tests in parallel across devices... U like it STAR it !
zerocode-tdd is a community-developed, free, open-source, outcome-driven automated testing framework for Data Pipelines, ETL, REST API, Kafka(Data Streams), Databases and Load scenarios. all defined in simple JSON or YAML — with zero coding.
Metrics exporter for Amazon AWS CloudWatch
A software library of stochastic streaming algorithms, a.k.a. sketches.
🚀 fast JavaScript 4 Eclipse Vert.x
Fast and reliable message broker built on top of Kafka.
A continuation of the popular Artemis ECS framework
Overlap2D Game development toolkit for UI and Level design
A simple way to pack and manage texture atlases for libGDX game framework.
a pug implementation written in Java (formerly known as jade)
Fast, lightweight, and RFC 4180 compliant CSV library for Java. Zero dependencies, ~90 KiB. Trusted by Apache NiFi, JUnit, and Neo4j.
Classic point and click adventure game engine and editor
A scientific charting library focused on performance optimised real-time data visualisation at 25 Hz update rates for data sets with a few 10 thousand up to 5 million data points.
Customize Skin, Cape and Elytra in Minecraft 1.8-1.21
Dicoogle - Open Source PACS
DeepfakeHTTP is a web server that uses HTTP dumps as a source for responses.
DAO oriented database mapping framework for Java
The New Official Aparapi: a framework for executing native Java and Scala code on the GPU.
The open-source Java obfuscation tool working with Ant and Gradle by yWorks - the diagramming experts
Language-agnostic pretty-printing through machine learning (uh, like, is this possible? YES, apparently).
eXist Native XML Database and Application Platform
Data Structures and Algorithms in Java (useful in interview process)
Unleash public transport data in your Java project.
Provides additional date-time classes that complement those in JDK 8
The Java pathfinder that ended the era of “good enough”
Detect uses of legacy Java APIs
An HTTP bridge for Apache Kafka®
Control your Canon or Nikon DSLR camera from your Android device through USB
Provides tracing abstractions over tracers and tracing system reporters.
⚗️ Lightweight HTTP extensions for Java & Kotlin
JVM support for Apollo Federation
GLTF 2.0 3D format support and PBR shader implementation for LibGDX
A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).
TrackMate is your buddy for your everyday tracking.
Manage local photos on Android: gallery, geotag with photomap, privacy, tags, find, sort, view, copy, send, ... .
PETEP (PEnetration TEsting Proxy) is an open-source Java application for traffic analysis & modification using TCP/UDP proxies. PETEP is a useful tool for performing penetration tests of applications with various application protocols. ⚡
Data Quality and Observability platform for the whole data lifecycle, from profiling new data sources to full automation with Data Observability. Configure data quality checks from the UI or in YAML files, let DQOps run the data quality checks daily to detect data quality issues.
Deploy, execute, manage process-based applications made with Bonita studio or through Engine APIs
AET - a system that detects visual changes on web sites and performs basic page health checks
Chemical 2D structure editor application/applet based on the Chemistry Development Kit
Program to help choose moves in the Pokemon Shuffle puzzle game
Reflectionless command line parser
Gateleen is a RESTful middleware toolkit for building API gateways
Open Quartermaster is an open source inventory management system, designed to be simple to use yet powerful and extendable. The last inventory management system you will ever need!
Java-based tool that validates General Transit Feed Specification (GTFS)-realtime feeds
LLM and agent evaluation for Java & Kotlin. Runs in JUnit and CI. Spring AI, LangChain4j, Koog, Embabel, and any LLM client.
Zookeeper service discovery bundle and client for dropwizard.
Capacitor plugin to create application with "kiosk mode". An app with this plugin can be set as an Android launcher.
Modern & Powerful Telegram-bot-api framework/library with custom features!
Web Console for Apache Wicket
A J2ME-focused reverse-engineering, decompilation and remapping toolkit, aimed at semantically correct, recompilable output.
Capacitor plugin for App Attest on iOS and Play Integrity attestation on Android
Implementation of ImageView for Android that supports zooming, by various touch gestures.
Modern Java - A Guide to Java 8
:fireworks: A well-designed local image and video selector for Android
Ultra Pull to Refresh for Android. Support all the views.
A util for setting status bar style on Android App.
A Material Design ViewPager easy to use library
SweetAlert for Android, a beautiful and clever alert dialog
A custom ViewPager title strip which gives continuous feedback to the user when scrolling
An Android library that help you to build app with swipe back gesture.
An amazing and convenient Android image slider.
A Java library that models spring dynamics and adds real world physics to your app.
Side menu with some categories to choose.
A small Android library allowing you to have a smooth and customizable horizontal or circular indeterminate ProgressBar
Android component which presents a dismissible view from the bottom of the screen
Vert.x examples
[DEPRECATED] A swipe menu for ListView.