701.googleapis / google-http-java-client
Google HTTP Client Library for Java
Ranked by Attention Score: stars gained over the last 90 complete days
701–800 of 1,312 by Attention Score · Aug 6, 2026 – Nov 3, 2026 (UTC)
Google HTTP Client Library for Java
Layout and functional testing framework for websites
Elegant parsing in Java and Scala - lightweight, easy-to-use, powerful.
📄The reliable, generic, fast and flexible logging framework for Android
This project is a plugin that supports ChatGPT running on JetBrains series IDE.
Write JSON unit tests in less code. Great for testing REST interfaces.
Metrics exporter for Amazon AWS CloudWatch
Zero-allocation hashing for Java
Fast, lightweight, and RFC 4180 compliant CSV library for Java. Zero dependencies, ~90 KiB. Trusted by Apache NiFi, JUnit, and Neo4j.
Binary Artifact Management Tool
Shell for issuing SQL to relational databases via JDBC
The open-source Java obfuscation tool working with Ant and Gradle by yWorks - the diagramming experts
Graphify is a Neo4j unmanaged extension used for document and text classification using graph-based hierarchical pattern recognition.
An extensible Java framework for building event-driven applications that break up XML and non-XML data into chunks for data integration
An open source, a high-performance hybrid integration platform that allows developers quick integration with any application, data, or system.
Published on Maven Central Java Library that compares 2 images with the same sizes and shows the differences visually by drawing rectangles. Some parts of the image can be excluded from the comparison. Can be used for automation QA tests.
Detect uses of legacy Java APIs
Control your Canon or Nikon DSLR camera from your Android device through USB
Java reporting library for creating dynamic report designs at runtime
Declarative UI for Java
A search interface and wayback machine for the UKWA Solr based warc-indexer framework.
Collection of mathematical morphology methods and plugins for ImageJ
Capacitor plugin for native audio engine.
Open Quartermaster is an open source inventory management system, designed to be simple to use yet powerful and extendable. The last inventory management system you will ever need!
The framework for quantification of neuronal anatomy
Capacitor plugin that allows camera interaction from Javascript and HTML
Anahata ASI - Artificial Super Intelligence - Cross-Platform, Modular, Enterprise Ready, Open Source, Pure Java, AGI and ASI Containers. Context Window Garbage Collector, Stateful Toolkits, Flight Recorder. Autonomous Observable Auditable JVM Agent with JIT java code execution. Anahata ASI SDK, Anahata ASI Desktop, Anahata ASI Studio - NetBeans.
A J2ME-focused reverse-engineering, decompilation and remapping toolkit, aimed at semantically correct, recompilable output.
Powerful and flexible library for loading, caching and displaying images on Android.
Project vlayout is a powerfull LayoutManager extension for RecyclerView, it provides a group of layouts for RecyclerView. Make it able to handle a complicate situation when grid, list and other layouts in the same recyclerview.
TranslatedOkGo - 3.0 arrives with a bang. This library is a network request framework based on the HTTP protocol that wraps OkHttp. It is simpler and easier to use than Retrofit, supports RxJava and RxJava2, supports custom caching, and supports batch resumable download management and batch upload management
Ultra Pull to Refresh for Android. Support all the views.
Tools for keeping your cloud operating in top form. Chaos Monkey is a resiliency tool that helps applications tolerate random instance failures.
A custom ViewPager title strip which gives continuous feedback to the user when scrolling
An Android library that help you to build app with swipe back gesture.
EditText in Material Design
[DEPRECATED] An Android library which allows developers to easily add animations to ListView items
Side menu with some categories to choose.
Project Malmo is a platform for Artificial Intelligence experimentation and research built on top of Minecraft. We aim to inspire a new generation of research into challenging new problems presented by this unique environment. --- For installation instructions, scroll down to *Getting Started* below, or visit the project page for more information:
Vert.x examples
An elegant way to show your menu or messages.
BinNavi is a binary analysis IDE that allows to inspect, navigate, edit and annotate control flow graphs and call graphs of disassembled code.
Unirest in Java: Simplified, lightweight HTTP client library.
TranslatedA beautiful and powerful SeekBar what supports single、 range、steps、vetical、custom (A beautiful and powerful SeekBar that supports single-direction and two-direction range selection, steps, vertical orientation, and high customizability)
Joda-Time library with Android specialization
Android Animation Easing Functions. Let's make animation more real!
RxJava types that are both an Observable and a Consumer.
jOOλ - The Missing Parts in Java 8 jOOλ improves the JDK libraries in areas where the Expert Group's focus was elsewhere. It adds tuple support, function support, and a lot of additional functionality around sequential Streams. The JDK 8's main efforts (default methods, lambdas, and the Stream API) were focused around maintaining backwards compatibility and implementing a functional API for parallelism.
A library that checks for your apps' updates on Google Play, GitHub, Amazon, F-Droid or your own server. API 9+ required.
The repository host gives no description.
GS Collections has been migrated to the Eclipse Foundation, re-branded as Eclipse Collections. https://www.eclipse.org/collections/
A Java to JavaScript transpiler.
Minimal UI library for Android inspired by React
Android drawer icon with material design animation
A pure-Java Markdown processor based on a parboiled PEG parser supporting a number of extensions
Make Slack and Facebook Bots in Java.
:fire: Powerful and modernized popup menu with fully customizable animations.
Immutable in-memory R-tree and R*-tree implementations in Java with reactive api
Spring HATEOAS - Library to support implementing representations for hyper-text driven REST web services.
AWS SDK for Android. For more information, see our web site:
Provides situational awareness of Industrial Control Systems (ICS) and Supervisory Control and Data Acquisition (SCADA) networks in support of network security assessments. #nsacyber
Google Play game services - Android samples
The Stack Overflow clone for your team (self-hosted or hosted)
MariaDB Embedded in Java JAR
Provide support to increase developer productivity in Java when using Neo4j. Uses familiar Spring concepts such as a template classes for core API usage and lightweight repository style data access.
Neo4j Spatial is a library of utilities for Neo4j that faciliates the enabling of spatial operations on data. In particular you can add spatial indexes to already located data, and perform spatial operations on the data like searching for data within specified regions or within a specified distance of a point of interest.
ATTENTION: This repository is a clone of https://gitlab.structr.com/structr/structr. All development/issue tracking has moved there. | Structr is an integrated open-source low-code development and runtime environment that uses a graph database (Neo4j).
Overlap2D Game development toolkit for UI and Level design
Parallel Collectors is a toolkit easing parallel collection processing in Java using Stream API.
Create your Java crypto trading bot in minutes. Our Spring boot starter takes care of exchange connections, accounts, orders, trades, and positions so you can focus on building your strategies.
JD-Core is a JAVA decompiler written in JAVA.
🔐 An SSL library for configuring http client or server. Rich with features such as hot reloading ssl and trusting additional certificates during runtime, combining multiple keystores, loading pem files and os/jdk certificates, logging certificate information during ssl handshake, bypassing ssl configuration from other libraries and more
An extendible and configurable PDF manipulation layer library written in java.
The Railcraft Mod for Minecraft, source and development.
The New Official Aparapi: a framework for executing native Java and Scala code on the GPU.
A vector drawing editor for LaTeX (JavaFX).
Java utilities: DeepEquals, Converter, LRUCache, CompactMap/Set, CaseInsensitiveMap, UniqueIdGenerator, FastReader/Writer, and more. Zero dependencies, JDK 8+
Provides additional date-time classes that complement those in JDK 8
Android Library to make it easy to create an Code editor or IDE that support any languages and themes, with auto complete, auto indenting, snippets and more features
⚗️ Lightweight HTTP extensions for Java & Kotlin
A library of extended scalars for graphql-java
A Capacitor plugin that sends you geolocation updates, even while the app is in the background.
This is an engine that converts data of one structure to another, based on a configuration file which describes how. There is an accompanying syntax to make writing mappings easier and more robust.
A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).
Chrome DevTools java client.
PETEP (PEnetration TEsting Proxy) is an open-source Java application for traffic analysis & modification using TCP/UDP proxies. PETEP is a useful tool for performing penetration tests of applications with various application protocols. ⚡
Native library loader for extracting and loading native libraries from Java.