1.NationalSecurityAgency / ghidra
Ghidra is a software reverse engineering (SRE) framework
- software-analysis
- disassembler
- reverse-engineering
Ranked by Attention Score: stars gained over the last 90 complete days
78 repositories by Attention Score · Aug 5, 2026 – Nov 2, 2026 (UTC)
Ghidra is a software reverse engineering (SRE) framework
A tool for reverse engineering Android apk files
Open Source Identity and Access Management For Modern Applications and Services
Free implementation of Play Services
🦎 A lightweight, streaming-native, multi-protocol gateway for AI, APIs, and real-time data. Route LLM requests across providers, govern MCP tools, and connect Kafka, MQTT, and HTTP through one high-performance engine with shared security and observability.
No-root network monitor, firewall and PCAP dumper for Android
Cryptomator for Windows, macOS, and Linux: Secure client-side encryption for your cloud storage, ensuring privacy and control over your data.
A free, secure and open source app for Android to manage your 2-step verification tokens.
The ZAP by Checkmarx Core project
✨ 开源、免费、一站式 Java 权限认证框架,让鉴权变得简单、优雅!—— 登录认证、权限认证、分布式 Session 会话、微服务网关鉴权、SSO 单点登录、OAuth2.0 统一认证、jwt 集成、API Key 秘钥授权、API 参数签名
The modern Java bytecode editor
Open source alternative to Auth0 / Firebase Auth / AWS Cognito
A Java 8+ Jar & Android APK Reverse Engineering Suite (Decompiler, Editor, Debugger & More)
🏆Gitee 最有价值开源项目 🚀:100: 小而全而美的第三方登录开源组件。目前已支持Github、Gitee、微博、钉钉、百度、Coding、腾讯云开发者平台、OSChina、支付宝、QQ、微信、淘宝、Google、Facebook、抖音、领英、小米、微软、今日头条、Teambition、StackOverflow、Pinterest、人人、华为、企业微信、酷家乐、Gitlab、美团、饿了么、推特、飞书、京东、阿里云、喜马拉雅、Amazon、Slack和 Line 等第三方平台的授权登录。 Login, so easy!
A p2p, secure file storage, social network and application protocol
Distributed Peer-to-Peer Web Search Engine and Intranet Search Appliance
Video players (IJKplayer, ExoPlayer, MediaPlayer), HTTPS, 16k page size, danmaku (bullet chat) support, external subtitles, support for filters, watermarks, and GIF screenshots, pre-roll and mid-roll ads, multiple simultaneous playback, basic seeking/dragging, volume and brightness adjustment, play-while-cache support
Empowering Data Intelligence with Distributed SQL for Sharding, Scalability, and Security Across All Databases.
Decompiler from Java bytecode to Java, used in IntelliJ IDEA.
循序渐进,学习Spring Boot、Spring Boot & Shiro、Spring Batch、Spring Cloud、Spring Cloud Alibaba、Spring Security & Spring Security OAuth2,博客Spring系列源码:https://mrbird.cc
Java JWT: JSON Web Token for Java and Android
Zuul is a gateway service that provides dynamic routing, monitoring, resiliency, security, and more.
Apereo CAS - Identity & Single Sign On for all earthlings and beyond.
Terasology - open source voxel world
eladmin jpa 版本:项目基于 Spring Boot 2.7.18、 Jpa、 Spring Security、Redis、Vue的前后端分离的后台管理系统,项目采用分模块开发方式, 权限控制采用 RBAC,支持数据字典与数据权限管理,支持一键生成前后端代码,支持动态路由
Automated testing to find logic and performance bugs in database systems
Gravitee.io - OpenSource API Management
Tsunami is a general purpose network security scanner with an extensible plugin system for detecting high severity vulnerabilities with high confidence.
Android virtual machine and deobfuscator
🔐 A CLI tool to extract server certificates
API Gateway bridging modern and legacy APIs with WSDL-to-OpenAPI, SOAP-to-REST, XML, OAuth2, and GraphQL.
Vulnerable Android application for developers and security enthusiasts to learn about Android insecurities
The SpotBugs plugin for security audits of Java web applications and Android applications. (Also work with Kotlin, Groovy and Scala projects)
Free database schema discovery and comprehension tool
OpenAM is an open-source access management solution for identity authentication, authorization, and federation. It provides single sign-on, adaptive authentication, and centralized policy control, enabling secure access to web, mobile, and cloud applications
Security engine for Java (authentication, authorization, multi frameworks): OpenID Connect, SAML2, CAS, OAuth, LDAP, JWT...
Library for OpenAPI 3 with spring-boot
Android Package Inspector - dynamic analysis with api hooks, start unexported activities and more. (Xposed Module)
Tink is a multi-language, cross-platform, open source library that provides cryptographic APIs that are secure, easy to use correctly, and hard(er) to misuse.
Bastillion gives you a clean, browser-based way to manage SSH access across all your systems—like a bastion host with a friendly dashboard.
Java implementation of Tink
Oversecured Vulnerable Android App
Java library to analyse Portable Executable files with a special focus on malware analysis and PE malformation robustness
SirixDB is an an embeddable, bitemporal, append-only database system and event store, storing immutable lightweight snapshots. It keeps the full history of each resource. Every commit stores a space-efficient snapshot through structural sharing. It is log-structured and never overwrites data. SirixDB uses a novel page-level versioning approach.
Java cryptographic library that supports Argon2, bcrypt, scrypt and PBKDF2 aimed to protect passwords in databases. Easy to use by design, highly customizable, secure and portable. All the implementations follow the standards and have been reviewed to perform better in the JVM.
:coffee: SonarSource Static Analyzer for Java Code Quality and Security
OpenDJ is an open-source LDAP directory server written in Java. It provides robust, scalable, and secure directory services for identity management, access control, and authentication in enterprise environments. OpenDJ supports LDAPv3 standard, replication, REST APIs, and high-performance
OpenAS2 is a java-based implementation of the EDIINT AS2 standard. It is intended to be used as a server. It is extremely configurable and supports a wide variety of signing and encryption algorithms.
Simple API, Complex Emails (Jakarta Mail smtp wrapper)
Android Vulnerability Test Suite - In the spirit of open data collection, and with the help of the community, let's take a pulse on the state of Android security. NowSecure presents an on-device app to test for recent device vulnerabilities.
Secure biometric authentication for Capacitor with Face ID, Touch ID, and Android biometrics.
Zero-allocation hashing for Java
🔐 An SSL library for configuring http client or server. Rich with features such as hot reloading ssl and trusting additional certificates during runtime, combining multiple keystores, loading pem files and os/jdk certificates, logging certificate information during ssl handshake, bypassing ssl configuration from other libraries and more
A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).
OpenIG is an open-source identity gateway (reverse-proxy) that secures, routes, and manages web traffic. It enables authentication, access control, and integration with identity providers, delivering single sign-on and API security for web and cloud applications.
A J2ME-focused reverse-engineering, decompilation and remapping toolkit, aimed at semantically correct, recompilable output.
BinNavi is a binary analysis IDE that allows to inspect, navigate, edit and annotate control flow graphs and call graphs of disassembled code.
Provides situational awareness of Industrial Control Systems (ICS) and Supervisory Control and Data Acquisition (SCADA) networks in support of network security assessments. #nsacyber
PETEP (PEnetration TEsting Proxy) is an open-source Java application for traffic analysis & modification using TCP/UDP proxies. PETEP is a useful tool for performing penetration tests of applications with various application protocols. ⚡
A lightweight, simple FTP server. Pure Java, no dependencies.
轻量级DDD正向/逆向业务建模框架,支撑复杂业务系统的架构演化!
Google OAuth Client Library for Java
Manage local photos on Android: gallery, geotag with photomap, privacy, tags, find, sort, view, copy, send, ... .
HOTP/TOTP one time passwords on java phones (J2ME)
🔐 Tutorial of setting up Security for your API with one way authentication with TLS/SSL and mutual authentication for a java based web server and a client with both Spring Boot. Different clients are provided such as Apache HttpClient, OkHttp, Spring RestTemplate, Spring WebFlux WebClient Jetty and Netty, the old and the new JDK HttpClient, the old and the new Jersey Client, Google HttpClient, Unirest, Retrofit, Feign, Methanol, vertx, Scala client Finagle, Featherbed, Dispatch Reboot, AsyncHttpClient, Sttp, Akka, Requests Scala, Http4s Blaze, Kotlin client Fuel, http4k, Kohttp and ktor. Also other server examples are available such as jersey with grizzly. Also gRPC, WebSocket and ElasticSearch examples are included
A Java library that implements a ByteChannel interface over SSLEngine, enabling easy-to-use (socket-like) TLS for Java applications.
A system for distributing and managing secrets
Generic Capacitor OAuth 2 client plugin. Stop the war in Ukraine!
Java binding to the Networking and Cryptography (NaCl) library with the awesomeness of libsodium
Android Secure SharedPreferences Using Facebook Conceal Encryption
Vuldroid is a Vulnerable Android Application made with security issues in order to demonstrate how they can occur in code
Java library for interacting with the Waves blockchain.
Dropwizard Authentication Module for LDAP using JNDI.
GraphQL implementation based on light-4j
JSON Web Token implementation for Java according to RFC 7519. Easily create, parse and validate JSON Web Tokens using a fluent API.
Unified Java API for multiple decompilers (Fernflower, Vineflower, Procyon, CFR, JD-Core, JADX)