1.toon-format / toon
🎒 Token-Oriented Object Notation (TOON) – compact, human-readable serialization of JSON data for LLM prompts. TypeScript SDK, CLI, benchmarks.
- data-format
- llm
- serialization
- tokenization
Ranked by Attention Score: stars gained over the last 180 complete days
1–100 of 142 by Attention Score · May 9, 2026 – Nov 4, 2026 (UTC)
🎒 Token-Oriented Object Notation (TOON) – compact, human-readable serialization of JSON data for LLM prompts. TypeScript SDK, CLI, benchmarks.
Extremely fast, in memory, serialization, reflection, and RPC library for C++. JSON, BEVE, BSON, CBOR, CSV, JSONB, MessagePack, TOML, YAML, EETF
The fastest JSON library in C
Fast and powerful CSV (delimited text) parser that gracefully handles large files and malformed input
Header-only TOML config file parser and serializer for C++17.
A C++20 library for fast serialization, deserialization and validation using reflection. Supports JSON, Avro, Boost Serialization, BSON, Cap'n Proto, CBOR, Cereal, Command line interfaces, CSV, Environment variables, flexbuffers, msgpack, parquet, TOML, UBJSON, XML, YAML, yas / msgpack.org[C++20]
📟 JSON library for Arduino and embedded C++. Simple and efficient.
Json.NET is a popular high-performance JSON framework for .NET
Jsmn is a world fastest JSON parser/tokenizer. This is the official repo replacing the old one at Bitbucket
Validate XML, Parse XML and Build XML rapidly without C/C++ based libraries and no callback.
The better way to deal with JSON data in Swift.
:spider_web: input/output for many mesh formats
CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.
HTML parsing/serialization toolset for Node.js. WHATWG HTML Living Standard (aka HTML5)-compliant.
A lightweight C++20 serialization and RPC library
A modern C++ CSV parser and serializer that doesn't make you choose between ease of use or performance.
Cista is a simple, high-performance, zero-copy C++ serialization & reflection library.
Alba is a JSON serializer for Ruby, JRuby and TruffleRuby.
TOML for Modern C++
One of the World's Fastest .NET CSV Parsers. Modern, minimal, fast, zero allocation, reading and writing of separated values (`csv`, `tsv` etc.). Cross-platform, trimmable and AOT/NativeAOT compatible with blazing fast SIMD vectorized parsing.
A lightweight library for converting complex objects to and from simple Python datatypes.
FeedKit is a Swift library for Reading and Generating RSS, Atom, and JSON feeds.
Cross-platform C++ library providing a simple API to read and write INI-style configuration files
Rapid YAML - a library to parse and emit YAML, and do it fast.
Parse and stringify URL query strings
Python module that makes working with XML feel like you are working with JSON
Fastest end-to-end CSV ingestion for Ruby (with C acceleration). SmarterCSV auto-detects formats, applies smart defaults, and returns Rails-ready hashes for seamless use with ActiveRecord, Sidekiq, parallel jobs, and S3 pipelines — even for messy user-uploaded real-world data.
Dependency free PHP library that helps to map any input into a strongly-typed structure.
A Sweet and Swifty YAML parser.
Fast JSON parser and validator for Go. No custom structs, no code generation, no reflection
A .NET MIME creation and parser library with support for S/MIME, PGP, DKIM, TNEF and Unix mbox spools.
:steam_locomotive: Decodes url.Values into Go value(s) and Encodes Go value(s) into url.Values. Dual Array and Full map support.
An advanced, modern networking library for Luau/Roblox
A high-performance 100% compatible drop-in replacement of "encoding/json"
idiomatic codec and rpc lib for msgpack, cbor, json, etc. msgpack.org[Go]
INI file reader and writer
The fastest deep cloning library for .NET – zero-config, works out of the box.
Python Module for Tabular Datasets in XLS, CSV, JSON, YAML, &c.
Fast, lightweight, and RFC 4180 compliant CSV library for Java. Zero dependencies, ~90 KiB. Trusted by Apache NiFi, JUnit, and Neo4j.
ActiveModel::Serializer implementation and Rails hooks
Simple, Fast, and Declarative Serialization Library for Ruby
Fully feature complete YAML parser and emitter, supporting the latest YAML spec and passing the full YAML testsuite.
A Rust JSON5 serializer and deserializer which speaks Serde.
✉️ A streaming Go library for the Internet Message Format and mail messages
CSV data manipulation made easy in PHP
Streaming csv parser inspired by binary-csv that aims to be faster than everyone else
A C++ header-only parser for the PLY file format. Parse .ply happily!
Jbuilder: generate JSON objects with a Builder-style DSL
Fast Binary Encoding is ultra fast and universal serialization solution for C++, C#, Go, Java, JavaScript, Kotlin, Python, Ruby, Swift
Header-only C++11 library to encode/decode base64, base64url, base32, base32hex and hex (a.k.a. base16) as specified in RFC 4648, plus Crockford's base32. MIT licensed with consistent, flexible API.
Clojure JSON and JSON SMILE (binary json format) encoding/decoding
csvutil provides fast and idiomatic mapping between CSV and Go (golang) values.
A header-only and easy to use Ini file parser for C++.
Codable extensions using Swift Macro
A correct and safe(er) JSON RFC 8259 reader/writer with sane defaults.
Better Codable through Property Wrappers
JSON to DataSet and DataSet to JSON converter for Delphi and Lazarus (FPC)
Easy XML parsing using Codable protocols in Swift
A fast, convenient and nonintrusive conversion framework between JSON and model. Your model class doesn't need to extend any base class. You don't need to modify any model file.
Schema.org objects turned into strongly typed C# POCO classes for use in .NET. All classes can be serialized into JSON/JSON-LD and XML, typically used to represent structured data in the head section of html page.
Laravel Serializable Closure provides an easy and secure way to serialize closures in PHP.
🍡 HTTP Input for Go - HTTP Request from/to Go Struct (Bi-directional Data Binding between Go Struct and http.Request)
A few classes for extremely fast json parsing/serializing in modern C++. Possibly the fastest json parser in C++. Possibly the fastest json serializer in C++.
XML to JavaScript object converter.
📜 Package for working with Valve's text and binary KeyValue format
✨ Next-gen C++ JSON Serialization Engine | Zero Dependency | Header-Only | Unleash JSON Potential
MUS format serializer for Go
Definitely Fastest and Zero Allocation JSON Serializer for C#(NET, .NET Core, Unity, Xamarin).
Library for (de-)serializing data of any complexity (supports JSON, and XML)
Extensions giving Swift's Codable API type inference super powers 🦸♂️🦹♀️
Infinitely Fast Deserializer for .NET, .NET Core and Unity.
EDI Serializer/Deserializer. Supports EDIFact, X12 and TRADACOMS formats