1.toon-format / toon
🎒 Token-Oriented Object Notation (TOON) – compact, human-readable serialization of JSON data for LLM prompts. TypeScript SDK, CLI, benchmarks.
- data-format
- llm
- serialization
- tokenization
Ranked by Attention Score: stars gained over the last 30 complete days
97 repositories by Attention Score · Oct 6, 2026 – Nov 4, 2026 (UTC)
🎒 Token-Oriented Object Notation (TOON) – compact, human-readable serialization of JSON data for LLM prompts. TypeScript SDK, CLI, benchmarks.
Extremely fast, in memory, serialization, reflection, and RPC library for C++. JSON, BEVE, BSON, CBOR, CSV, JSONB, MessagePack, TOML, YAML, EETF
The fastest JSON library in C
📟 JSON library for Arduino and embedded C++. Simple and efficient.
A C++20 library for fast serialization, deserialization and validation using reflection. Supports JSON, Avro, Boost Serialization, BSON, Cap'n Proto, CBOR, Cereal, Command line interfaces, CSV, Environment variables, flexbuffers, msgpack, parquet, TOML, UBJSON, XML, YAML, yas / msgpack.org[C++20]
Header-only TOML config file parser and serializer for C++17.
Jsmn is a world fastest JSON parser/tokenizer. This is the official repo replacing the old one at Bitbucket
Fast and powerful CSV (delimited text) parser that gracefully handles large files and malformed input
Json.NET is a popular high-performance JSON framework for .NET
Alba is a JSON serializer for Ruby, JRuby and TruffleRuby.
Parse and stringify URL query strings
:spider_web: input/output for many mesh formats
CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.
TOML for Modern C++
A .NET MIME creation and parser library with support for S/MIME, PGP, DKIM, TNEF and Unix mbox spools.
One of the World's Fastest .NET CSV Parsers. Modern, minimal, fast, zero allocation, reading and writing of separated values (`csv`, `tsv` etc.). Cross-platform, trimmable and AOT/NativeAOT compatible with blazing fast SIMD vectorized parsing.
A Sweet and Swifty YAML parser.
A modern C++ CSV parser and serializer that doesn't make you choose between ease of use or performance.
A lightweight C++20 serialization and RPC library
A lightweight library for converting complex objects to and from simple Python datatypes.
FeedKit is a Swift library for Reading and Generating RSS, Atom, and JSON feeds.
Validate XML, Parse XML and Build XML rapidly without C/C++ based libraries and no callback.
Cista is a simple, high-performance, zero-copy C++ serialization & reflection library.
Extensions giving Swift's Codable API type inference super powers 🦸♂️🦹♀️
Rapid YAML - a library to parse and emit YAML, and do it fast.
Python Module for Tabular Datasets in XLS, CSV, JSON, YAML, &c.
HTML parsing/serialization toolset for Node.js. WHATWG HTML Living Standard (aka HTML5)-compliant.
Fast JSON parser and validator for Go. No custom structs, no code generation, no reflection
Clojure JSON and JSON SMILE (binary json format) encoding/decoding
Cross-platform C++ library providing a simple API to read and write INI-style configuration files
A C++ header-only parser for the PLY file format. Parse .ply happily!
Dependency free PHP library that helps to map any input into a strongly-typed structure.
csvutil provides fast and idiomatic mapping between CSV and Go (golang) values.
Fast Binary Encoding is ultra fast and universal serialization solution for C++, C#, Go, Java, JavaScript, Kotlin, Python, Ruby, Swift
:steam_locomotive: Decodes url.Values into Go value(s) and Encodes Go value(s) into url.Values. Dual Array and Full map support.
INI file reader and writer
✉️ A streaming Go library for the Internet Message Format and mail messages
Abstract JSON for Golang with JSONPath support
An advanced, modern networking library for Luau/Roblox
Python module that makes working with XML feel like you are working with JSON
Streaming csv parser inspired by binary-csv that aims to be faster than everyone else
A fast & lightweight XML & HTML parser in Swift with XPath & CSS support
JSON to DataSet and DataSet to JSON converter for Delphi and Lazarus (FPC)
Header-only C++11 library to encode/decode base64, base64url, base32, base32hex and hex (a.k.a. base16) as specified in RFC 4648, plus Crockford's base32. MIT licensed with consistent, flexible API.
Fast, lightweight, and RFC 4180 compliant CSV library for Java. Zero dependencies, ~90 KiB. Trusted by Apache NiFi, JUnit, and Neo4j.
Schema.org objects turned into strongly typed C# POCO classes for use in .NET. All classes can be serialized into JSON/JSON-LD and XML, typically used to represent structured data in the head section of html page.
EDI Serializer/Deserializer. Supports EDIFact, X12 and TRADACOMS formats
Codable extensions using Swift Macro
The fastest deep cloning library for .NET – zero-config, works out of the box.
Fully feature complete YAML parser and emitter, supporting the latest YAML spec and passing the full YAML testsuite.
A Rust JSON5 serializer and deserializer which speaks Serde.
The better way to deal with JSON data in Swift.
CSV data manipulation made easy in PHP
Infinitely Fast Deserializer for .NET, .NET Core and Unity.
Definitely Fastest and Zero Allocation JSON Serializer for C#(NET, .NET Core, Unity, Xamarin).
Better Codable through Property Wrappers
Easy XML parsing using Codable protocols in Swift
Lightweight, extremely high-performance JSON parser for C++11
CSV Decoding and Encoding for Elixir
tar-stream is a streaming tar parser and generator.
A header-only and easy to use Ini file parser for C++.
Easy to use, easy to extend and high-performance library for CSV parsing with .NET
🍡 HTTP Input for Go - HTTP Request from/to Go Struct (Bi-directional Data Binding between Go Struct and http.Request)
Zero Allocation Writer/Reader Parser for .NET Core
A reasonably fast, easy to use and 100% conformant Elixir library for Google Protocol Buffers (aka protobuf)
Package ethernet implements marshaling and unmarshaling of IEEE 802.3 Ethernet II frames and IEEE 802.1Q VLAN tags. MIT Licensed.
A correct and safe(er) JSON RFC 8259 reader/writer with sane defaults.
An implementation of RDF for Elixir
A few classes for extremely fast json parsing/serializing in modern C++. Possibly the fastest json parser in C++. Possibly the fastest json serializer in C++.
A fast, robust, richly-featured table serialisation library for Lua