1.toon-format / toon
🎒 Token-Oriented Object Notation (TOON) – compact, human-readable serialization of JSON data for LLM prompts. TypeScript SDK, CLI, benchmarks.
- data-format
- llm
- serialization
- tokenization
Ranked by Attention Score: stars gained over the last 7 complete days
56 repositories by Attention Score · Oct 29, 2026 – Nov 4, 2026 (UTC)
🎒 Token-Oriented Object Notation (TOON) – compact, human-readable serialization of JSON data for LLM prompts. TypeScript SDK, CLI, benchmarks.
The fastest JSON library in C
Parse and stringify URL query strings
Extremely fast, in memory, serialization, reflection, and RPC library for C++. JSON, BEVE, BSON, CBOR, CSV, JSONB, MessagePack, TOML, YAML, EETF
A C++20 library for fast serialization, deserialization and validation using reflection. Supports JSON, Avro, Boost Serialization, BSON, Cap'n Proto, CBOR, Cereal, Command line interfaces, CSV, Environment variables, flexbuffers, msgpack, parquet, TOML, UBJSON, XML, YAML, yas / msgpack.org[C++20]
Jsmn is a world fastest JSON parser/tokenizer. This is the official repo replacing the old one at Bitbucket
:spider_web: input/output for many mesh formats
📟 JSON library for Arduino and embedded C++. Simple and efficient.
Fast JSON parser and validator for Go. No custom structs, no code generation, no reflection
Header-only TOML config file parser and serializer for C++17.
A Sweet and Swifty YAML parser.
Validate XML, Parse XML and Build XML rapidly without C/C++ based libraries and no callback.
Clojure JSON and JSON SMILE (binary json format) encoding/decoding
One of the World's Fastest .NET CSV Parsers. Modern, minimal, fast, zero allocation, reading and writing of separated values (`csv`, `tsv` etc.). Cross-platform, trimmable and AOT/NativeAOT compatible with blazing fast SIMD vectorized parsing.
Cross-platform C++ library providing a simple API to read and write INI-style configuration files
TOML for Modern C++
A modern C++ CSV parser and serializer that doesn't make you choose between ease of use or performance.
CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.
A lightweight C++20 serialization and RPC library
INI file reader and writer
A C++ header-only parser for the PLY file format. Parse .ply happily!
Json.NET is a popular high-performance JSON framework for .NET
CSV data manipulation made easy in PHP
Infinitely Fast Deserializer for .NET, .NET Core and Unity.
Definitely Fastest and Zero Allocation JSON Serializer for C#(NET, .NET Core, Unity, Xamarin).
Extensions giving Swift's Codable API type inference super powers 🦸♂️🦹♀️
Streaming csv parser inspired by binary-csv that aims to be faster than everyone else
A fast & lightweight XML & HTML parser in Swift with XPath & CSS support
csvutil provides fast and idiomatic mapping between CSV and Go (golang) values.
Easy XML parsing using Codable protocols in Swift
Rapid YAML - a library to parse and emit YAML, and do it fast.
Fast, lightweight, and RFC 4180 compliant CSV library for Java. Zero dependencies, ~90 KiB. Trusted by Apache NiFi, JUnit, and Neo4j.
Schema.org objects turned into strongly typed C# POCO classes for use in .NET. All classes can be serialized into JSON/JSON-LD and XML, typically used to represent structured data in the head section of html page.
tar-stream is a streaming tar parser and generator.
Easy to use, easy to extend and high-performance library for CSV parsing with .NET
Fully feature complete YAML parser and emitter, supporting the latest YAML spec and passing the full YAML testsuite.
A Rust JSON5 serializer and deserializer which speaks Serde.
A few classes for extremely fast json parsing/serializing in modern C++. Possibly the fastest json parser in C++. Possibly the fastest json serializer in C++.