Trending repositories
Ranked by Attention Score: stars gained over the last 90 complete days
1–100 of 135 by Attention Score · Aug 7, 2026 – Nov 4, 2026 (UTC)
2.toon-format / toon
🎒 Token-Oriented Object Notation (TOON) – compact, human-readable serialization of JSON data for LLM prompts. TypeScript SDK, CLI, benchmarks.
- data-format
- llm
- serialization
- tokenization
4.stephenberry / glaze
Extremely fast, in memory, serialization, reflection, and RPC library for C++. JSON, BEVE, BSON, CBOR, CSV, JSONB, MessagePack, TOML, YAML, EETF
- api
- binary
- cplusplus
- cpp
- interface
- json
- +14 more
5.ibireme / yyjson
The fastest JSON library in C
- json
- c
- portable
- serialization
- deserialization
- cross-platform
- +3 more
7.marzer / tomlplusplus
Header-only TOML config file parser and serializer for C++17.
- toml
- cplusplus-17
- cplusplus-20
- header-only
- configuration-files
- cpp
- +14 more
8.mholt / PapaParse
Fast and powerful CSV (delimited text) parser that gracefully handles large files and malformed input
- csv
- javascript
- csv-parser
9.munich-data-engineering / reflect-cpp
A C++20 library for fast serialization, deserialization and validation using reflection. Supports JSON, Avro, Boost Serialization, BSON, Cap'n Proto, CBOR, Cereal, Command line interfaces, CSV, Environment variables, flexbuffers, msgpack, parquet, TOML, UBJSON, XML, YAML, yas / msgpack.org[C++20]
10.bblanchon / ArduinoJson
📟 JSON library for Arduino and embedded C++. Simple and efficient.
- arduino
- c-plus-plus
- iot
- embedded
- arduino-library
- json
- +2 more
13.zserge / jsmn
Jsmn is a world fastest JSON parser/tokenizer. This is the official repo replacing the old one at Bitbucket
- json-data
- json-string
- parsing
15.JamesNK / Newtonsoft.Json
Json.NET is a popular high-performance JSON framework for .NET
- json
- c-sharp
18.nschloe / meshio
:spider_web: input/output for many mesh formats
- vtk
- pypi
- python
- mesh
- mathematics
- engineering
- +1 more
19.fxamacker / cbor
CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.
- cbor
- rfc-8949
- cose
- cwt
- go
- golang
- +7 more
20.inikulin / parse5
HTML parsing/serialization toolset for Node.js. WHATWG HTML Living Standard (aka HTML5)-compliant.
21.felixguendling / cista
Cista is a simple, high-performance, zero-copy C++ serialization & reflection library.
- serialization
- cpp
- cpp17
- reflection
- deserialization
- efficient
- +3 more
23.SwiftyJSON / SwiftyJSON
The better way to deal with JSON data in Swift.
- swiftyjson
- json
- swift
- response
- request
- carthage
- +4 more
24.vincentlaucsb / csv-parser
A modern C++ CSV parser and serializer that doesn't make you choose between ease of use or performance.
- csv
- parser
- json
- tab-separated
- csv-parser
- statistics
- +5 more
25.NaturalIntelligence / fast-xml-parser
Validate XML, Parse XML and Build XML rapidly without C/C++ based libraries and no callback.
- fast-xml-parser
- xml2json
- xml2js
- fast
- xml
- parser
- +11 more
26.okuramasafumi / alba
Alba is a JSON serializer for Ruby, JRuby and TruffleRuby.
- json-serializer
- json-serialization
- ruby
- performance
- json
- presenter
- +1 more
27.brofield / simpleini
Cross-platform C++ library providing a simple API to read and write INI-style configuration files
28.ToruNiina / toml11
TOML for Modern C++
- toml
- c-plus-plus-11
- c-plus-plus
- parser
- serializer
- c-plus-plus-14
- +4 more
30.eyalz800 / zpp_bits
A lightweight C++20 serialization and RPC library
- serialization
- cpp
- header-only
- rpc
- cpp20
31.nietras / Sep
One of the World's Fastest .NET CSV Parsers. Modern, minimal, fast, zero allocation, reading and writing of separated values (`csv`, `tsv` etc.). Cross-platform, trimmable and AOT/NativeAOT compatible with blazing fast SIMD vectorized parsing.
- csharp
- csv
- csv-parser
- csv-reader
- csv-writer
- dotnet
- +2 more
32.marshmallow-code / marshmallow
A lightweight library for converting complex objects to and from simple Python datatypes.
- serialization
- deserialization
- validation
- python
- marshalling
- serde
- +1 more
33.sindresorhus / query-string
Parse and stringify URL query strings
- query-string
- urlsearchparams
- url
- stringify
- parse
- npm-package
34.martinblech / xmltodict
Python module that makes working with XML feel like you are working with JSON
36.jstedfast / MimeKit
A .NET MIME creation and parser library with support for S/MIME, PGP, DKIM, TNEF and Unix mbox spools.
37.nmdias / FeedKit
FeedKit is a Swift library for Reading and Generating RSS, Atom, and JSON feeds.
- rss
- atom
- swift
- rss-reader
- atom-feed-parser
- atom-reader
- +4 more
38.jpsim / Yams
A Sweet and Swifty YAML parser.
40.biojppm / rapidyaml
Rapid YAML - a library to parse and emit YAML, and do it fast.
- yaml
- json
- parser
- emitter
- serialization
- rapid
- +6 more
41.CuyZ / Valinor
Dependency free PHP library that helps to map any input into a strongly-typed structure.
43.callum-oakley / json5-rs
A Rust JSON5 serializer and deserializer which speaks Serde.
44.jazzband / tablib
Python Module for Tabular Datasets in XLS, CSV, JSON, YAML, &c.
45.ugorji / go
idiomatic codec and rpc lib for msgpack, cbor, json, etc. msgpack.org[Go]
47.go-playground / form
:steam_locomotive: Decodes url.Values into Go value(s) and Encodes Go value(s) into url.Values. Dual Array and Full map support.
- decoding
- encoder
- form
- parser
- form-data
48.valyala / fastjson
Fast JSON parser and validator for Go. No custom structs, no code generation, no reflection
- json-parser
- fast
- golang
- go
- json
- json-validation
49.pantoniou / libfyaml
Fully feature complete YAML parser and emitter, supporting the latest YAML spec and passing the full YAML testsuite.
50.ffrostfall / ByteNet
An advanced, modern networking library for Luau/Roblox
- buffer
- luau
- netcode
- networking
- roblox
51.nmwsharp / happly
A C++ header-only parser for the PLY file format. Parse .ply happily!
52.lofcz / FastCloner
The fastest deep cloning library for .NET – zero-config, works out of the box.
- deep-clone
- deep-copy
- deepclone
- deepcopy
- duplication
- cloner
- +11 more
53.metayeti / mINI
INI file reader and writer
- ini-file
- ini-reader
- ini-writer
- ini-parser
- ini-config
- ini
- +1 more
54.Zulu-Inuoe / jzon
A correct and safe(er) JSON RFC 8259 reader/writer with sane defaults.
56.thephpleague / csv
CSV data manipulation made easy in PHP
- php
- csv-document
- csv-converter
- csv-filter
- csv-query
- csv
57.chronoxor / FastBinaryEncoding
Fast Binary Encoding is ultra fast and universal serialization solution for C++, C#, Go, Java, JavaScript, Kotlin, Python, Ruby, Swift
- performance
- serialization
- binary
- protocol
- low-latency
- cpp
- +9 more
60.Rookfighter / inifile-cpp
A header-only and easy to use Ini file parser for C++.
- ini-parser
- inifile
- cpp
- cpp-library
63.dakrone / cheshire
Clojure JSON and JSON SMILE (binary json format) encoding/decoding
64.mafintosh / csv-parser
Streaming csv parser inspired by binary-csv that aims to be faster than everyone else
65.procore-oss / blueprinter
Simple, Fast, and Declarative Serialization Library for Ruby
- ruby
- rails
- json
- serializer
- resource-serializer
- presenter
66.jszwec / csvutil
csvutil provides fast and idiomatic mapping between CSV and Go (golang) values.
- golang
- csv
- fast
- csv-parser
- go
- csvutil
- +6 more
67.tplgy / cppcodec
Header-only C++11 library to encode/decode base64, base64url, base32, base32hex and hex (a.k.a. base16) as specified in RFC 4648, plus Crockford's base32. MIT licensed with consistent, flexible API.
68.emersion / go-message
✉️ A streaming Go library for the Internet Message Format and mail messages
- mime
69.spyzhov / ajson
Abstract JSON for Golang with JSONPath support
- golang
- golang-package
- json
- json-parser
- jsonpath
70.CoderMJLee / MJExtension
A fast, convenient and nonintrusive conversion framework between JSON and model. Your model class doesn't need to extend any base class. You don't need to modify any model file.
- objective-c
- model
- json
- dictionary
- array
71.rails-api / active_model_serializers
ActiveModel::Serializer implementation and Rails hooks
- ruby
- json
- resource-serializer
72.JohnSundell / Codextended
Extensions giving Swift's Codable API type inference super powers 🦸♂️🦹♀️
- swift
- codable
- json-parsing
- type-inference
74.osiegmar / FastCSV
Fast, lightweight, and RFC 4180 compliant CSV library for Java. Zero dependencies, ~90 KiB. Trusted by Apache NiFi, JUnit, and Neo4j.
- csv
- java
- csv-parser
- csv-reader
- zero-dependency
75.RehanSaeed / Schema.NET
Schema.org objects turned into strongly typed C# POCO classes for use in .NET. All classes can be serialized into JSON/JSON-LD and XML, typically used to represent structured data in the head section of html page.
- schema
- schema-org
- dotnet
- c-sharp
- dotnet-core
- poco
- +4 more
76.TinyCsvParser / TinyCsvParser
Easy to use, easy to extend and high-performance library for CSV parsing with .NET
- csv-parser
77.marksands / BetterCodable
Better Codable through Property Wrappers
- property-wrappers
- codable
- swift5-1
- swift-package-manager
78.CoreOffice / XMLCoder
Easy XML parsing using Codable protocols in Swift
- xml
- xml-parser
- swift
- swift4
- codable
- carthage
- +4 more
79.laravel / serializable-closure
Laravel Serializable Closure provides an easy and secure way to serialize closures in PHP.
- php
- serialize
- closure
80.mafintosh / tar-stream
tar-stream is a streaming tar parser and generator.
81.reers / ReerCodable
Codable extensions using Swift Macro
- ananda
- codable
- mjextension
- yymodel
- bettercodable
- codablewrapper
- +12 more
83.ValvePython / vdf
📜 Package for working with Valve's text and binary KeyValue format
85.json-iterator / goArchived
A high-performance 100% compatible drop-in replacement of "encoding/json"
- go
- golang
- parser
- json-parser
- json
- serialization
- +2 more
86.rails / jbuilder
Jbuilder: generate JSON objects with a Builder-style DSL
87.neuecc / Utf8JsonArchived
Definitely Fastest and Zero Allocation JSON Serializer for C#(NET, .NET Core, Unity, Xamarin).
88.tilo / smarter_csv
Fastest end-to-end CSV ingestion for Ruby (with C acceleration). SmarterCSV auto-detects formats, applies smart defaults, and returns Rails-ready hashes for seamless use with ActiveRecord, Sidekiq, parallel jobs, and S3 pipelines — even for messy user-uploaded real-world data.
- csv
- csv-converter
- csv-export
- csv-file
- csv-files
- csv-format
- +11 more
89.cezheng / Fuzi
A fast & lightweight XML & HTML parser in Swift with XPath & CSS support
- xml
- xml-parsing
- xml-parser
- xpath
- html
- html-parsing
- +6 more
90.viniciussanchez / dataset-serialize
JSON to DataSet and DataSet to JSON converter for Delphi and Lazarus (FPC)
- delphi
- dataset
- json
- converter
- serialize
- dataset-serialize
- +10 more
92.ggicci / httpin
🍡 HTTP Input for Go - HTTP Request from/to Go Struct (Bi-directional Data Binding between Go Struct and http.Request)
- go-http
- go-http-middleware
- go-api
- go-rest-api
- http-request-params-reader
- go
- +2 more
93.6bee / Remote.Linq
Simply LINQ your remote resources...
- linq-expressions
- arbitrary-linq-queries
- expression-trees
- entity
- entity-framework
- remote
- +3 more
94.leandromoh / RecordParser
Zero Allocation Writer/Reader Parser for .NET Core
- flatfile
- csv
- tsv
- delimited
- file
- dotnet-core
- +8 more
95.MistEO / meojson
✨ Next-gen C++ JSON Serialization Engine | Zero Dependency | Header-Only | Unleash JSON Potential
- json
- cpp
- parser
- json5
- serialization
96.mus-format / mus-go
MUS format serializer for Go
- golang
- serialization
- codegen
- data-validation
- high-performance
- zero-allocation
- +1 more
97.JensBorrisholt / Delphi-JsonToDelphiClass
Generates Delphi Classes based on JSON string (Json To Delphi Class Generator / JSON Data Binding Tool)
- json
- delphi
- delphi10
- dto-generator
- dto
- dtoclass
- +1 more
98.neuecc / ZeroFormatterArchived
Infinitely Fast Deserializer for .NET, .NET Core and Unity.
- c-sharp
- unity
- serializer
- binaryformat
99.schmittjoh / serializer
Library for (de-)serializing data of any complexity (supports JSON, and XML)