1.supertone-oss-archive / supertonicArchived
Lightning-Fast, On-Device, Multilingual TTS — running natively via ONNX.
Ranked by Attention Score: stars gained over the last 180 complete days
1–100 of 105 by Attention Score · May 7, 2026 – Nov 2, 2026 (UTC)
Lightning-Fast, On-Device, Multilingual TTS — running natively via ONNX.
Browse media content with your own rules on Android TV
This open-source curriculum introduces the fundamentals of Model Context Protocol (MCP) through real-world, cross-language examples in .NET, Java, TypeScript, JavaScript, Rust and Python. Designed for developers, it focuses on practical techniques for building modular, scalable, and secure AI workflows from session setup to service orchestration.
All Algorithms implemented in Java
Jenkins automation server
Build cross-platform Native Progressive Web Apps for iOS, Android, and the Web ⚡️
The fast, precise document-intelligence engine for every language: text, tables and metadata from 100+ formats, with OCR, transcription and code intelligence.
Everything you need to know to get the job.
Desktop app for managing BibTeX and BibLaTeX (.bib) libraries
Dive into this repository, a comprehensive resource covering Data Structures, Algorithms, 450 DSA by Love Babbar, Striver DSA sheet, Apna College DSA Sheet, and FAANG Questions! 🚀 That's not all! We've got Technical Subjects like Operating Systems, DBMS, SQL, Computer Networks, and Object-Oriented Programming, all waiting for you.
👶🏻 신입 개발자 전공 지식 & 기술 면접 백과사전 📖
The official Java SDK for Model Context Protocol servers and clients. Maintained in collaboration with Spring AI
The modern Java bytecode editor
⚡ Write Native with TypeScript ✨ Best of all worlds (TypeScript, Swift, Objective C, Kotlin, Java, Dart). Use what you love ❤️ Angular, React, Solid, Svelte, Vue with: iOS (UIKit, SwiftUI), Android (View, Jetpack Compose), Flutter and you name it compatible.
Um guia extenso de informações com um vasto conteúdo de várias áreas para ajudar, agregar conhecimento e retirar dúvidas, nesse guia você encontrará tudo que necessário para qualquer carreira relacionada a tecnologia.
🚀一个用来深入学习并实战 Spring Boot 的项目。
A static analyzer for Java, C, C++, and Objective-C
An app for creating push notifications for new messages posted to gotify/server.
Testcontainers is a Java library that supports JUnit tests, providing lightweight, throwaway instances of common databases, Selenium web browsers, or anything else that can run in a Docker container.
Roadmap to becoming a Java developer in 2026
jsoup: the Java HTML parser, built for HTML editing, cleaning, scraping, and XSS safety.
Turn any website into clean, structured data: Markdown, metadata and links from one page or a whole site, in every major language.
Most popular Mocking framework for unit tests written in Java
Java / JavaFX / Kotlin Game Library (Engine)
A tool to help eliminate NullPointerExceptions (NPEs) in your Java code with low build-time overhead
一位酷爱做饭的程序员,立志用动画将算法说的通俗易懂。我的面试网站 www.chengxuchu.com
A better build tool for Java, Scala and Kotlin: Simpler than Maven, easier than Gradle, with 3-7x faster dev workflows than other JVM build tools
The Java pathfinder that ended the era of “good enough”
A tool for generating code based on a GraphQL schema and GraphQL operations (query/mutation/subscription), with flexible support for custom plugins.
Declarative Java engine for structured documents. Automatic layout, pagination, reusable templates and themes. Render print-ready PDF, export editable PowerPoint, or generate semantic DOCX.
Thumbnailator - a thumbnail generation library for Java
Mixin is a trait/mixin and bytecode weaving framework for Java using ASM
Modern Java - A Guide to Java 8
A Database of Real Faults and an Experimental Infrastructure to Enable Controlled Experiments in Software Engineering Research
Java library for the Stripe API.
Cucumber for the JVM
An extensible Java library for HTTP request and response logging
LLM and agent evaluation for Java & Kotlin. Runs in JUnit and CI. Spring AI, LangChain4j, Koog, Embabel, and any LLM client.
Transform ML models into a native code (Java, C, Python, Go, JavaScript, Visual Basic, C#, R, PowerShell, PHP, Dart, Haskell, Ruby, F#, Rust) with zero dependencies
A library for communication with a Minecraft client/server.
👨🎓 Java Core Sprout : basic, concurrent, algorithm
iWF is a Workflow-As-Code microservice orchestration platform offering an orchestration coding framework and service for building resilient, fault-tolerant, scalable long-running processes
AI Code Completions
The goal of this project is to allow integrated or USB-connected webcams to be accessed directly from Java. Using provided libraries users are able to read camera images and detect motion. Main project consist of several sub projects - the root one, which contains required classes, build-in webcam driver compatible with Windows, Linux and Mac OS, which can stream images as fast as your camera can serve them (up to 50 FPS). Main project can be used standalone, but user is able to replace build-in driver with different one - such as OpenIMAJ, GStreamer, V4L4j, JMF, LTI-CIVIL, FMJ, etc.
Fast, lightweight, and RFC 4180 compliant CSV library for Java. Zero dependencies, ~90 KiB. Trusted by Apache NiFi, JUnit, and Neo4j.
A thin Java wrapper to access the Steamworks API
The open-source Java obfuscation tool working with Ant and Gradle by yWorks - the diagramming experts
Free self-hosted mangas/comics/light novels media server
The project demonstrates how you can develop applications with Jakarta EE using widely adopted architectural best practices like Domain-Driven Design (DDD).
GraphQL Java implementation
:snowboarder: EJDB2 — Embeddable JSON Database engine C library. Simple XPath like query language (JQL).
Binary Artifact Management Tool
A customizable and easy to use BottomBar navigation view with sleek animations, with support for ViewPager, ViewPager2, NavController, and badges.
Fast Binary Encoding is ultra fast and universal serialization solution for C++, C#, Go, Java, JavaScript, Kotlin, Python, Ruby, Swift
OpenAPI (f.k.a Swagger) Specification code generator. Supports C#, PowerShell, Go, Java, Node.js, TypeScript, Python
An OkHttp interceptor which has pretty logger for request and response. +Mock support
A Java library to use the OpenAI Api in the simplest possible way.
Life is too short to google for dependencies and versions
A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).
Java library that provides an interface to directly interact with Valve's Steam servers.
Android Library to make it easy to create an Code editor or IDE that support any languages and themes, with auto complete, auto indenting, snippets and more features
Semantic versioning for Java apps.
Bootstrap style widgets for Android, with Glyph Icons
Object-Oriented Java primitives, as an alternative to Google Guava and Apache Commons
PipelinR is a lightweight command processing pipeline ❍ ⇢ ❍ ⇢ ❍ for your Java awesome app.
java port of Underscore.js
Event Sourcing and CQRS in practice.
Client-side response routing for Spring
Fast & memory efficient hash tables for Java
Neovim plugin for generating Java files (classes, interfaces, enums, records) with package-aware autocompletion.
Modern & Powerful Telegram-bot-api framework/library with custom features!
Refinement and functional value types for Java 8+
A schema-first tool for graphql-java inspired by graphql-tools for JS
Gradle plugin and CLI for computing code coverage of new/modified code based on a diff
Java Scientific Computing Library - Signal Processing, FFT, Filters, PSD, DCT, SciPy-like APIs for JVM & Android used in Machine Learning and Data Science.
A Material design back port of Android's CalendarView
An android library which provides a compact calendar view much like the one used in google calenders.
Minimal UI library for Android inspired by React
True Object-Oriented Java Web Framework without NULLs, Static Methods, Annotations, and Mutable Objects
Slack Developer Kit (including Bolt for Java) for any JVM language
A streaming JsonPath processor in Java
A Docker client for Java written in Kotlin and Groovy
A platform independent tensor library with autograd for the JVM
A library for easy integration of a flexible circular WidgetGroup within libGDX
OpenAI Api Client in Java
Port of a popular ruby faker gem written in kotlin. Generate realistically looking fake data such as names, addresses, banking details, and many more, that can be used for testing and data anonymization purposes.
Fast and Easy mapping from database and csv to POJO. A java micro ORM, lightweight alternative to iBatis and Hibernate. Fast Csv Parser and Csv Mapper
JVM support for Apollo Federation
A distributed event bus that implements a RESTful API abstraction on top of Kafka-like queues
A jOOQ-CodeGenerator to create vertx-ified DAOs and POJOs.
Ruby access to the clipboard on Windows, Linux, macOS, Java, WSL and more platforms 📋︎
AutoParams is a versatile test data generator designed for parameterized tests in Java and Kotlin.
Capacitor Plugin using native Google Maps SDK for Android and iOS.
SneakyThrow is a Java library to ignore checked exceptions
A simple graph library for java
JVM runtime execution analysis - finds hot code paths by frequency, not CPU time
The simple, stupid batch framework for Java