1.yuliskov / SmartTube
Browse media content with your own rules on Android TV
Ranked by Attention Score: stars gained over the last 30 complete days
78 repositories by Attention Score · Oct 4, 2026 – Nov 2, 2026 (UTC)
Browse media content with your own rules on Android TV
All Algorithms implemented in Java
Everything you need to know to get the job.
一款纯Vibe coding的Windows版TVbox
Build cross-platform Native Progressive Web Apps for iOS, Android, and the Web ⚡️
This open-source curriculum introduces the fundamentals of Model Context Protocol (MCP) through real-world, cross-language examples in .NET, Java, TypeScript, JavaScript, Rust and Python. Designed for developers, it focuses on practical techniques for building modular, scalable, and secure AI workflows from session setup to service orchestration.
The fast, precise document-intelligence engine for every language: text, tables and metadata from 100+ formats, with OCR, transcription and code intelligence.
Jenkins automation server
考研英语单词桌面小组件:按初试倒计时自动倒推每日词量,定时通知推送 + 桌面小组件 + 学习弹幕;内置 5398 词,支持自定义词库、深色模式、双语/仅英文/仅中文切换。纯本地运行,不联网、无账号。
Desktop app for managing BibTeX and BibLaTeX (.bib) libraries
👶🏻 신입 개발자 전공 지식 & 기술 면접 백과사전 📖
The official Java SDK for Model Context Protocol servers and clients. Maintained in collaboration with Spring AI
The modern Java bytecode editor
Dive into this repository, a comprehensive resource covering Data Structures, Algorithms, 450 DSA by Love Babbar, Striver DSA sheet, Apna College DSA Sheet, and FAANG Questions! 🚀 That's not all! We've got Technical Subjects like Operating Systems, DBMS, SQL, Computer Networks, and Object-Oriented Programming, all waiting for you.
⚡ Write Native with TypeScript ✨ Best of all worlds (TypeScript, Swift, Objective C, Kotlin, Java, Dart). Use what you love ❤️ Angular, React, Solid, Svelte, Vue with: iOS (UIKit, SwiftUI), Android (View, Jetpack Compose), Flutter and you name it compatible.
Um guia extenso de informações com um vasto conteúdo de várias áreas para ajudar, agregar conhecimento e retirar dúvidas, nesse guia você encontrará tudo que necessário para qualquer carreira relacionada a tecnologia.
A static analyzer for Java, C, C++, and Objective-C
一位酷爱做饭的程序员,立志用动画将算法说的通俗易懂。我的面试网站 www.chengxuchu.com
An app for creating push notifications for new messages posted to gotify/server.
Testcontainers is a Java library that supports JUnit tests, providing lightweight, throwaway instances of common databases, Selenium web browsers, or anything else that can run in a Docker container.
jsoup: the Java HTML parser, built for HTML editing, cleaning, scraping, and XSS safety.
A tool to help eliminate NullPointerExceptions (NPEs) in your Java code with low build-time overhead
Turn any website into clean, structured data: Markdown, metadata and links from one page or a whole site, in every major language.
Java / JavaFX / Kotlin Game Library (Engine)
🚀一个用来深入学习并实战 Spring Boot 的项目。
A tool for generating code based on a GraphQL schema and GraphQL operations (query/mutation/subscription), with flexible support for custom plugins.
Most popular Mocking framework for unit tests written in Java
Roadmap to becoming a Java developer in 2026
Lightning-Fast, On-Device, Multilingual TTS — running natively via ONNX.
A Database of Real Faults and an Experimental Infrastructure to Enable Controlled Experiments in Software Engineering Research
A better build tool for Java, Scala and Kotlin: Simpler than Maven, easier than Gradle, with 3-7x faster dev workflows than other JVM build tools
Mixin is a trait/mixin and bytecode weaving framework for Java using ASM
Java library for the Stripe API.
An extensible Java library for HTTP request and response logging
Declarative Java engine for structured documents. Automatic layout, pagination, reusable templates and themes. Render print-ready PDF, export editable PowerPoint, or generate semantic DOCX.
Cucumber for the JVM
GraphQL Java implementation
Free self-hosted mangas/comics/light novels media server
Bootstrap style widgets for Android, with Glyph Icons
Thumbnailator - a thumbnail generation library for Java
The goal of this project is to allow integrated or USB-connected webcams to be accessed directly from Java. Using provided libraries users are able to read camera images and detect motion. Main project consist of several sub projects - the root one, which contains required classes, build-in webcam driver compatible with Windows, Linux and Mac OS, which can stream images as fast as your camera can serve them (up to 50 FPS). Main project can be used standalone, but user is able to replace build-in driver with different one - such as OpenIMAJ, GStreamer, V4L4j, JMF, LTI-CIVIL, FMJ, etc.
:snowboarder: EJDB2 — Embeddable JSON Database engine C library. Simple XPath like query language (JQL).
Minimal UI library for Android inspired by React
Fast Binary Encoding is ultra fast and universal serialization solution for C++, C#, Go, Java, JavaScript, Kotlin, Python, Ruby, Swift
The Java pathfinder that ended the era of “good enough”
A Java library to use the OpenAI Api in the simplest possible way.
Error Prone extensions: extra bug checkers and a large battery of Refaster rules.
AI Code Completions
Transform ML models into a native code (Java, C, Python, Go, JavaScript, Visual Basic, C#, R, PowerShell, PHP, Dart, Haskell, Ruby, F#, Rust) with zero dependencies
An OkHttp interceptor which has pretty logger for request and response. +Mock support
A library for communication with a Minecraft client/server.
A schema-first tool for graphql-java inspired by graphql-tools for JS
Fast, lightweight, and RFC 4180 compliant CSV library for Java. Zero dependencies, ~90 KiB. Trusted by Apache NiFi, JUnit, and Neo4j.
The open-source Java obfuscation tool working with Ant and Gradle by yWorks - the diagramming experts
JVM support for Apollo Federation
A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).
Java library that provides an interface to directly interact with Valve's Steam servers.
Reflectionless command line parser
LLM and agent evaluation for Java & Kotlin. Runs in JUnit and CI. Spring AI, LangChain4j, Koog, Embabel, and any LLM client.
Modern & Powerful Telegram-bot-api framework/library with custom features!
Modern Java - A Guide to Java 8
A Material design back port of Android's CalendarView
OpenAPI (f.k.a Swagger) Specification code generator. Supports C#, PowerShell, Go, Java, Node.js, TypeScript, Python
An android library which provides a compact calendar view much like the one used in google calenders.
A customizable and easy to use BottomBar navigation view with sleek animations, with support for ViewPager, ViewPager2, NavController, and badges.
Binary Artifact Management Tool
iWF is a Workflow-As-Code microservice orchestration platform offering an orchestration coding framework and service for building resilient, fault-tolerant, scalable long-running processes
A beautiful material calendar with endless scroll, range selection and a lot more!
A thin Java wrapper to access the Steamworks API
java port of Underscore.js
Android Library to make it easy to create an Code editor or IDE that support any languages and themes, with auto complete, auto indenting, snippets and more features
Ruby access to the clipboard on Windows, Linux, macOS, Java, WSL and more platforms 📋︎
Semantic versioning for Java apps.
A library for easy integration of a flexible circular WidgetGroup within libGDX
The complete ngrok agent for Java: programmatic tunnels for ingress, inspection, webhooks, demos, and APIs
Refinement and functional value types for Java 8+