401.g200kg / webaudio-tinysynth
Light-weight GM mapped WebAudio-JavaScript Synthesizer Engine / MIDI Player
Ranked by Attention Score: stars gained over the last 180 complete days
401–500 of 573 by Attention Score · May 10, 2026 – Nov 5, 2026 (UTC)
Light-weight GM mapped WebAudio-JavaScript Synthesizer Engine / MIDI Player
Music typeset with the Lilypond system
Low latency, web based, open source, high quality, voice-over-ip intercom solution
A fluent API to FFMPEG (http://www.ffmpeg.org)
(Archived) An audio file player for macOS, inspired by Winamp.
🎹 Listen to free MIDI songs, download the best MIDI files, and share the best MIDIs on the web
Demux and mux MPEG Transport Streams (.ts) natively in GO
A Python library aimed at acousticians.
C++ implementation of RAVENNA AES67 ST2110-30 for desktop and (virtual) servers
Library and utilities to read and write broadcasting media files. Primarily supports the MXF file format
GPUImage 2 is a BSD-licensed Swift framework for GPU-accelerated video and image processing.
:musical_keyboard: Making life easy to create a MIDI-app on the web. Includes a library to program synesthesia into your app for memory recognition or for creating trippy effects. Convert soundfonts for Guitar, Bass, Drums, ect. into code that can be read by the browser. Supports multiple simultaneous instruments and perfect timing.
SitemapGenerator is a framework-agnostic XML Sitemap generator written in Ruby with automatic Rails integration. It supports Video, News, Image, Mobile, PageMap and Alternate Links sitemap extensions and includes Rake tasks for managing your sitemaps, as well as many other great features.
Concats a list of videos together using ffmpeg with sexy OpenGL transitions.
VLC-Qt - a simple library to connect Qt application with libVLC
DASH/Smooth HTML5 Video Player
p5.sound brings the Processing approach to Web Audio and p5.js. Demos:
A go implementation of the STUN client (RFC 3489 and RFC 5389)
A many speaker distributed music synthesizer using UDP multicast over WiFi
Web / REST interface for downloading youtube videos onto a server.
Play MusicXML scores in the browser using Web Audio and Web MIDI.
PowerToysRun-VideoDownloader is a plugin for Microsoft PowerToys Run that allows you to quickly download videos from various platforms (primarily YouTube) directly from your PowerToys Run interface. Simply type dl followed by a video URL to get started.
Capacitor plugin for native audio engine.
A beat detection utility which is using the Web Audio API.
Simple menu bar app to download YouTube movies on your Mac
MIDI library for Node.js and web-browsers
A library of drums patterns for music lovers 🎵 - Angular 22 - Scala3
Versatile Video Player implementation for iOS, macOS, and tvOS
Classify music genre from a 10 second sound stream using a Neural Network.
Generic library for real-time communications with async IO support
The gpodder.net webservice
Open-source DAW with a node graph system.
The world's only Open Source CPaaS with a Twilio compatible API
A githubbed version of DIY production intercom system based on Mumble voice chat server and headless client running on Raspberry Pis.
Capacitor plugin to play video in native player
A plugin for recording/exporting the output of Web Audio API nodes
YoutubeKit is a video player that fully supports Youtube IFrame API and YoutubeDataAPI for easily create a Youtube app
Inner ear models for Python
The EBU ADM Renderer, written in Python, is the reference implementation of EBU Tech 3388
Musical Scores for Piano with full sources in LilyPond file format
nvim-yt-player is a Neovim plugin for playing YouTube audio directly from Neovim using mpv + yt-dlp via IPC socket. Features include a premium ASCII visualizer UI, interactive search picker, queue editor, SponsorBlock integration, and full playback controls.
Capacitor plugin to record audio on iOS and Android, keep active in background
(UNMAINTAINED) A simple, beautiful podcast app for Windows, macOS, and Linux.
Airtime is Sourcefabric’s open source radio software for scheduling and remote station management. Airtime provides a reliable audio playout with sub-second precision, an improved interface with modern usability features, advanced user management supporting roles and a Google-style calendar to schedule and move shows and playlists.
Photon is a Java implementation of the Interoperable Master Format (IMF) standard. IMF is a SMPTE standard whose core constraints are defined in the specification st2067-2:2013
Allocators, I/O streams, math, geometry, image and audio processing for D
IVOZ Provider - Multitenant solution for VoIP telephony providers
interactive programming of melodies, producing MIDI
Audio synthesis from binary code of any file
Chord Charts. Evolved.
Capacitor plugin player to embed YouTube player controls in Capacitor apps
HTML5 QR code scanner using your webcam
This library provides common speech features for ASR including MFCCs and filterbank energies.
A recurrent neural network designed to generate classical music.
A video composition framework build on top of AVFoundation. It's simple to use and easy to extend.
[unmaintained] MIDI looper, modular synth and sampler app built using Web Audio and Web MIDI APIs
A cross-browser wrapper for the Web Audio API which aims to closely follow the standard.
Video++, a C++14 high performance video and image processing library.
FFmpeg filter for applying GLSL transitions between video streams.
Edit images and video with Swift concurrency, powered by Metal.
Fast and Easy Augmented Reality for the Web :rocket:
XMPP client for macOS based on TigaseSwift XMPP library
A new version of GBVideoPlayer with higher resolution, 3-bit stereo PCM audio and video compression
Youtube client based on Invidious API for Java devices with MIDP 2.0 support
A powerful cross-platform audio engine, optimized for games.
YouTube video player for iOS, tvOS and macOS
iOS 360° panorama video player with Metal rendering support (formerly HTY360Player)
A video player for iOS, based on AVPlayer, support the horizontal, vertical screen. support adjust volume, brightness and seek by slide, support subtitles.
My first venture into raspberry pi stuff. Running a custom pure data patch I've been working on for a couple years on a Raspberry Pi 3. This project took a couple months and I'm still tweaking stuff here and there but it's pretty much complete, it even survived it's first live show!
Basic Real-time AV Editor - allowing you to preview, mix, and route live audio and video streams on the cloud
📺 Flutter VLC powered video player.
cross-library (GStreamer + Core Audio + MAD + FFmpeg) audio decoding for Python
A dart-lang version of the SIP UA stack.
:notes: Library for declaratively manipulating the Web Audio API
Python implementation of the Short Term Objective Intelligibility measure
Polyrhythmically-inclined Midi Drum generator
🔄 Export and transcode media in Swift
Cloud Download Manager for direct links and media files from Youtube/Spotify/etc with media converter and builtin proxy to bypass restrictions
Advanced Cross Platform Audio Engine for libGDX based on MiniAudio
Capacitor plugin to run ffmpeg locally on device
Vireo is a lightweight and versatile video processing library written in C++11
#matrix is the online open-source workplace inspired in sococo.com for distributed teams to have the experience of work together each day, side-by-side. No matter where team members might be. Working in an online workplace is even more productive when people are feeling in the same space.
A music composition library for Clojure and Clojurescript.
Marsyas - Music Analysis, Retrieval and Synthesis for Audio Signals
A music player library for the PSG audio channels of the GB, GBC and GBA.
Sippy B2BUA is a RFC3261-compliant Session Initiation Protocol (SIP) stack and Back-to-back user agent (B2BUA) server software.