401.cbdevnet / midimonster
Multi-protocol control & translation software (ArtNet, MIDI, OSC, sACN, ...)
- midi
- artnet
- art-net
- protocol-adapter
- osc
- lighting
- +9 more
Ranked by Attention Score: stars gained over the last 30 complete days
401–500 of 521 by Attention Score · Oct 7, 2026 – Nov 5, 2026 (UTC)
Multi-protocol control & translation software (ArtNet, MIDI, OSC, sACN, ...)
A Python library aimed at acousticians.
📹 Open-source, self-hosted WebRTC 1-to-1 video calling for private real-time communication. Build secure browser-based consultations, coaching, support, telehealth, and other video call experiences with peer-to-peer communication and screen sharing.
Edit images and video with Swift concurrency, powered by Metal.
Synchronized video viewing with chat and other features (one-channel web service)
Music typeset with the Lilypond system
Low latency, web based, open source, high quality, voice-over-ip intercom solution
A library of drums patterns for music lovers 🎵 - Angular 22 - Scala3
TranslatedSupport customization of any player SDK and control layer
:musical_keyboard: Making life easy to create a MIDI-app on the web. Includes a library to program synesthesia into your app for memory recognition or for creating trippy effects. Convert soundfonts for Guitar, Bass, Drums, ect. into code that can be read by the browser. Supports multiple simultaneous instruments and perfect timing.
SitemapGenerator is a framework-agnostic XML Sitemap generator written in Ruby with automatic Rails integration. It supports Video, News, Image, Mobile, PageMap and Alternate Links sitemap extensions and includes Rake tasks for managing your sitemaps, as well as many other great features.
JeroMQ is a pure Java implementation of the ZeroMQ messaging library, offering high-performance asynchronous messaging for distributed or concurrent applications.
This library provides common speech features for ASR including MFCCs and filterbank energies.
Flutter Music Player - First Open Source Flutter based material design music player with audio plugin to play local music files.
Open-source compositing software. Node-graph based. Similar in functionalities to Adobe After Effects and Nuke by The Foundry.
Band.js - Music composer interface for the Web Audio API.
My first venture into raspberry pi stuff. Running a custom pure data patch I've been working on for a couple years on a Raspberry Pi 3. This project took a couple months and I'm still tweaking stuff here and there but it's pretty much complete, it even survived it's first live show!
League Director is a tool for staging and recording videos from League of Legends replays
DASH/Smooth HTML5 Video Player
Python library for reading audio file metadata
Versatile Video Player implementation for iOS, macOS, and tvOS
A go implementation of the STUN client (RFC 3489 and RFC 5389)
YoutubeKit is a video player that fully supports Youtube IFrame API and YoutubeDataAPI for easily create a Youtube app
🎹 Listen to free MIDI songs, download the best MIDI files, and share the best MIDIs on the web
A large collection of free and portable video plugins
The official mistserver source repository - www.mistserver.com
Package flac provides access to FLAC (Free Lossless Audio Codec) streams.
Sofia-SIP is an open-source SIP User-Agent library, compliant with the IETF RFC3261 specification.
Python's missing "algorave" module. Live code music with Python using MIDI, OSC and/or SuperCollider.
The gpodder.net webservice
Efficient sample rate conversion in python
Light-weight GM mapped WebAudio-JavaScript Synthesizer Engine / MIDI Player
IVOZ Provider - Multitenant solution for VoIP telephony providers
Sippy B2BUA is a RFC3261-compliant Session Initiation Protocol (SIP) stack and Back-to-back user agent (B2BUA) server software.
A video game library tracking web app built in Rails and powered by Wikidata.
Audio synthesis from binary code of any file
macOs Video Downloader written in Swift and Obj.-C
The world's only Open Source CPaaS with a Twilio compatible API
Open source intercom manager for broadcast production: manages intercom channels and users over WebRTC, using Symphony Media Bridge.
PowerToysRun-VideoDownloader is a plugin for Microsoft PowerToys Run that allows you to quickly download videos from various platforms (primarily YouTube) directly from your PowerToys Run interface. Simply type dl followed by a video URL to get started.
Library and utilities to read and write broadcasting media files. Primarily supports the MXF file format
Claude Code plugin for visual docs — annotated screenshots, feature demos, flow walkthrough recordings (gif/mp4), terminal captures and before/after composites, one command each. Self-contained Chromium, self-validated output, no MCP.
An open source iOS framework for GPU-based image and video processing
A plugin for recording/exporting the output of Web Audio API nodes
GPUImage 3 is a BSD-licensed Swift framework for GPU-accelerated video and image processing using Metal.
Painless high-performance audio on iOS and Mac OS X
Go package captcha implements generation and verification of image and audio CAPTCHAs.
Web Audio DAW. Use the Web Audio API for dynamic sound synthesis. It's like jQuery for your ears.
A recurrent neural network designed to generate classical music.
An audio effects library for the Web Audio API.
Library to simplify the way you create and manipulate sounds with the Web Audio API.
An experimental HTML5 & WebGL video composition and rendering API.
A simple C++ library for reading and writing audio files.
A captcha library that generates audio and image CAPTCHAs.
Concats a list of videos together using ffmpeg with sexy OpenGL transitions.
#matrix is the online open-source workplace inspired in sococo.com for distributed teams to have the experience of work together each day, side-by-side. No matter where team members might be. Working in an online workplace is even more productive when people are feeling in the same space.
:guitar: A maestro of pitch detection.
A music player that connects to your cloud/distributed storage.
(UNMAINTAINED) A simple, beautiful podcast app for Windows, macOS, and Linux.
The reliable YouTube API Ruby client
Video++, a C++14 high performance video and image processing library.
Basic Real-time AV Editor - allowing you to preview, mix, and route live audio and video streams on the cloud
A Swift wrapper for the FFmpeg API
📺 Flutter VLC powered video player.
A macOS GUI for youtube-dl
The Amazing Audio Engine is a sophisticated framework for iOS audio applications, built so you don't have to.
C++ wrapper for FFmpeg
A flutter package for editing video written in pure Dart with fully customizable UI. Supports crop, trim, rotation and cover selection.
A music composition library for Clojure and Clojurescript.
:tv: A free and simple to use video player made with Haskell.
Marsyas - Music Analysis, Retrieval and Synthesis for Audio Signals
:musical_note: A tool for programmatic audio performance in the browser using Javascript.
Fast, JavaScript DSP library that creates JIT optimized audio callbacks using code generation techniques
A dart-lang version of the SIP UA stack.
A playout client for Windows/Linux/macOS that will let you control CasparCG Server, BMD ATEM, OBS Studio, vMix, OSC-compatible devices, HTTP (REST)-compatible devices, and more!
A many speaker distributed music synthesizer using UDP multicast over WiFi
Web / REST interface for downloading youtube videos onto a server.
A music player library for the PSG audio channels of the GB, GBC and GBA.
3D 180/360 video player for macOS and PSVR
NYT360Video plays 360-degree video streamed from an AVPlayer on iOS.
Fast and Easy Augmented Reality for the Web :rocket:
NI Media is a C++ library for reading and writing audio streams.
A library for augmenting annotated audio data
LibXtract is a simple, portable, lightweight library of audio feature extraction functions.
interactive programming of melodies, producing MIDI
XMPP client for macOS based on TigaseSwift XMPP library
iOS 360-degree video player streaming from an AVPlayer.
DSP algorithms for chord detection + key estimation