401.transitive-bullshit / ffmpeg-concat
Concats a list of videos together using ffmpeg with sexy OpenGL transitions.
Ranked by Attention Score: stars gained over the last 90 complete days
401–500 of 591 by Attention Score · Aug 8, 2026 – Nov 5, 2026 (UTC)
Concats a list of videos together using ffmpeg with sexy OpenGL transitions.
A music player that connects to your cloud/distributed storage.
A go implementation of the STUN client (RFC 3489 and RFC 5389)
🎹 Listen to free MIDI songs, download the best MIDI files, and share the best MIDIs on the web
Generic library for real-time communications with async IO support
QCTools (Quality Control Tools for Video Preservation) is a free and open source software tool that helps users analyze and understand their digitized video files through use of audiovisual analytics and filtering. QCTools is funded by the National Endowment for the Humanities and the Knight Foundation, and is developed by the Bay Area Video Coalition.
Package flac provides access to FLAC (Free Lossless Audio Codec) streams.
Web / REST interface for downloading youtube videos onto a server.
Light-weight GM mapped WebAudio-JavaScript Synthesizer Engine / MIDI Player
Music typeset with the Lilypond system
Play MusicXML scores in the browser using Web Audio and Web MIDI.
Low latency, web based, open source, high quality, voice-over-ip intercom solution
:iphone: :movie_camera: A powerful and completely customizable media player for iOS
GPUImage 3 is a BSD-licensed Swift framework for GPU-accelerated video and image processing using Metal.
A Python library aimed at acousticians.
C++ wrapper for FFmpeg
Allocators, I/O streams, math, geometry, image and audio processing for D
A video game library tracking web app built in Rails and powered by Wikidata.
A githubbed version of DIY production intercom system based on Mumble voice chat server and headless client running on Raspberry Pis.
Library and utilities to read and write broadcasting media files. Primarily supports the MXF file format
:musical_keyboard: Making life easy to create a MIDI-app on the web. Includes a library to program synesthesia into your app for memory recognition or for creating trippy effects. Convert soundfonts for Guitar, Bass, Drums, ect. into code that can be read by the browser. Supports multiple simultaneous instruments and perfect timing.
:musical_note: A Mac app wrapper for music.youtube.com
A fast and extensible gapless AudioPlayer/AudioStreamer for OSX and iOS (iPhone, iPad)
This library provides common speech features for ASR including MFCCs and filterbank energies.
A recurrent neural network designed to generate classical music.
(Archived) An audio file player for macOS, inspired by Winamp.
My first venture into raspberry pi stuff. Running a custom pure data patch I've been working on for a couple years on a Raspberry Pi 3. This project took a couple months and I'm still tweaking stuff here and there but it's pretty much complete, it even survived it's first live show!
VLC-Qt - a simple library to connect Qt application with libVLC
A cross-browser wrapper for the Web Audio API which aims to closely follow the standard.
A Swift wrapper for the FFmpeg API
Demux and mux MPEG Transport Streams (.ts) natively in GO
Edit images and video with Swift concurrency, powered by Metal.
The gpodder.net webservice
Fast and Easy Augmented Reality for the Web :rocket:
Audio synthesis from binary code of any file
The world's only Open Source CPaaS with a Twilio compatible API
PowerToysRun-VideoDownloader is a plugin for Microsoft PowerToys Run that allows you to quickly download videos from various platforms (primarily YouTube) directly from your PowerToys Run interface. Simply type dl followed by a video URL to get started.
A powerful cross-platform audio engine, optimized for games.
Capacitor plugin for native audio engine.
C++ implementation of RAVENNA AES67 ST2110-30 for desktop and (virtual) servers
TranslatedA Chinese-language guide to digital subscriptions and AI tools, including subscription instructions, risk warnings, and an FAQ.
GPUImage 2 is a BSD-licensed Swift framework for GPU-accelerated video and image processing.
A plugin for recording/exporting the output of Web Audio API nodes
Shim to insulate apps from spec changes and prefix differences. Latest adapter.js release:
YouTube video player for iOS, tvOS and macOS
SitemapGenerator is a framework-agnostic XML Sitemap generator written in Ruby with automatic Rails integration. It supports Video, News, Image, Mobile, PageMap and Alternate Links sitemap extensions and includes Rake tasks for managing your sitemaps, as well as many other great features.
Vireo is a lightweight and versatile video processing library written in C++11
:guitar: A maestro of pitch detection.
Versatile Video Player implementation for iOS, macOS, and tvOS
The reliable YouTube API Ruby client
Video++, a C++14 high performance video and image processing library.
A beat detection utility which is using the Web Audio API.
MIDI library for Node.js and web-browsers
Fast, JavaScript DSP library that creates JIT optimized audio callbacks using code generation techniques
Python implementation of the Short Term Objective Intelligibility measure
A many speaker distributed music synthesizer using UDP multicast over WiFi
A music player library for the PSG audio channels of the GB, GBC and GBA.
deezer.com Player (CLI & VSCode)
Photon is a Java implementation of the Interoperable Master Format (IMF) standard. IMF is a SMPTE standard whose core constraints are defined in the specification st2067-2:2013
Sippy B2BUA is a RFC3261-compliant Session Initiation Protocol (SIP) stack and Back-to-back user agent (B2BUA) server software.
Tuttle OFX is a library to connect and batch operations with OpenFx plugins. It comes with a set of plugins that allows you to batch process on movies and file sequences.
Open-source DAW with a node graph system.
The EBU ADM Renderer, written in Python, is the reference implementation of EBU Tech 3388
macOs Video Downloader written in Swift and Obj.-C
Musical Scores for Piano with full sources in LilyPond file format
Discover your unique music story. Explore your top tracks, artists, genres, and musical eras.
nvim-yt-player is a Neovim plugin for playing YouTube audio directly from Neovim using mpv + yt-dlp via IPC socket. Features include a premium ASCII visualizer UI, interactive search picker, queue editor, SponsorBlock integration, and full playback controls.
Capacitor plugin to record audio on iOS and Android, keep active in background
adds support for playing opus files in love2d. Send patches :)
Simple animated GIF screen recorder with an easy to use interface
captcha of base64 image string
Painless high-performance audio on iOS and Mac OS X
A video player for iOS, based on AVPlayer, support the horizontal, vertical screen. support adjust volume, brightness and seek by slide, support subtitles.
This package provides an integration with FFmpeg for Laravel. Laravel's Filesystem handles the storage of the files.
An experimental HTML5 & WebGL video composition and rendering API.
Band.js - Music composer interface for the Web Audio API.
#matrix is the online open-source workplace inspired in sococo.com for distributed teams to have the experience of work together each day, side-by-side. No matter where team members might be. Working in an online workplace is even more productive when people are feeling in the same space.
(UNMAINTAINED) A simple, beautiful podcast app for Windows, macOS, and Linux.
AudioPlayer is syntax and feature sugar over AVPlayer. It plays your audio files (local & remote).
FFmpeg filter for applying GLSL transitions between video streams.
Expressive Digital Signal Processing (DSP) package for Python
Basic Real-time AV Editor - allowing you to preview, mix, and route live audio and video streams on the cloud
YoutubeKit is a video player that fully supports Youtube IFrame API and YoutubeDataAPI for easily create a Youtube app
Airtime is Sourcefabric’s open source radio software for scheduling and remote station management. Airtime provides a reliable audio playout with sub-second precision, an improved interface with modern usability features, advanced user management supporting roles and a Google-style calendar to schedule and move shows and playlists.
Classify music genre from a 10 second sound stream using a Neural Network.