401.SimpleITK / SimpleITK
SimpleITK: a layer built on top of the Insight Toolkit (ITK), intended to simplify and facilitate ITK's use in rapid prototyping, education and interpreted languages.
Ranked by Attention Score: stars gained over the last 30 complete days
401–500 of 545 by Attention Score · Oct 4, 2026 – Nov 2, 2026 (UTC)
SimpleITK: a layer built on top of the Insight Toolkit (ITK), intended to simplify and facilitate ITK's use in rapid prototyping, education and interpreted languages.
zerocode-tdd is a community-developed, free, open-source, outcome-driven automated testing framework for Data Pipelines, ETL, REST API, Kafka(Data Streams), Databases and Load scenarios. all defined in simple JSON or YAML — with zero coding.
Bloop is a build server and CLI tool to compile, test and run Scala fast from any editor or build tool.
A library for communication with a Minecraft client/server.
🚀 fast JavaScript 4 Eclipse Vert.x
A schema-first tool for graphql-java inspired by graphql-tools for JS
Zircon is an extensible and user-friendly, multiplatform tile engine.
Fast, lightweight, and RFC 4180 compliant CSV library for Java. Zero dependencies, ~90 KiB. Trusted by Apache NiFi, JUnit, and Neo4j.
Universal, flexible, high-performance distributed ID generator. | 通用、灵活、高性能的分布式 ID 生成器
A scientific charting library focused on performance optimised real-time data visualisation at 25 Hz update rates for data sets with a few 10 thousand up to 5 million data points.
Customize Skin, Cape and Elytra in Minecraft 1.8-1.21
The New Official Aparapi: a framework for executing native Java and Scala code on the GPU.
The open-source Java obfuscation tool working with Ant and Gradle by yWorks - the diagramming experts
eXist Native XML Database and Application Platform
Unleash public transport data in your Java project.
A powerful, platform-independent, visual editor for complex 2D worlds and scenes.
arara is a TeX automation tool based on rules and directives. It gives you a way to enhance your TeX experience. This is a mirror repository.
Detect uses of legacy Java APIs
Modern Reactive CQRS Architecture Microservice development framework based on DDD and EventSourcing | 基于 DDD & EventSourcing 的现代响应式 CQRS 架构微服务开发框架
Provides tracing abstractions over tracers and tracing system reporters.
JVM support for Apollo Federation
A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).
No description provided by the repository host.
Deploy, execute, manage process-based applications made with Bonita studio or through Engine APIs
Chemical 2D structure editor application/applet based on the Chemistry Development Kit
Java library that provides an interface to directly interact with Valve's Steam servers.
Snapshot testing for Java, Kotlin, and the JVM
Computer Graphics and Gaming API (Vulkan, OpenGL, GLFW, STB, ...) bindings for Java using Java 22 FFM APIs
Reflectionless command line parser
TypeDB Drivers for Rust, Python, Java, Node.js, C, C++, and C#.
LLM and agent evaluation for Java & Kotlin. Runs in JUnit and CI. Spring AI, LangChain4j, Koog, Embabel, and any LLM client.
A code-first BDD testing framework for Kotlin & Java.
Tired of screen fragmentation? AppDimens is the unified solution for responsive, pixel-perfect UI across all platforms and devices. It offers adaptive scaling (SDP, SSP, Dynamic, Fixed) for Kotlin, Compose, XML Views, Swift, and SwiftUI, ensuring layouts and fonts scale perfectly from the smallest to the largest device.
Modern & Powerful Telegram-bot-api framework/library with custom features!
Modern Java - A Guide to Java 8
This is a collection of tutorials for learning how to use Docker with various tools. Contributions welcome.
A declarative API to handle Android runtime permissions.
An asynchronous, callback-based Http client for Android built on top of Apache's HttpClient libraries.
A damn simple library for building production-ready RESTful web services.
A fast build system that encourages the creation of small, reusable modules over a variety of platforms and languages.
A Material Design ViewPager easy to use library
A library to bring fully animated Material Design components to pre-Lolipop Android.
A Material design back port of Android's CalendarView
Advanced dialog solution for android
OpenAPI (f.k.a Swagger) Specification code generator. Supports C#, PowerShell, Go, Java, Node.js, TypeScript, Python
You can easily add awesome animated context menu to your app.
requery - modern SQL based query & persistence for Java / Kotlin / Android
Material Design implementation for Android 4.0+. Shadows, ripples, vectors, fonts, animations, widgets, rounded corners and more.
Master repository for the JGraphT project
Implementation of various string similarity and distance algorithms: Levenshtein, Jaro-winkler, n-Gram, Q-Gram, Jaccard index, Longest Common Subsequence edit distance, cosine similarity ...
Learn, design or document codebase by putting breadcrumbs in source code. Live updates, multi-language support and more.
[deprecated] Animations for Android L drawer, back, dismiss and check icons
[deprecated] Android L Ripple effect wrapper for Views
Cheat Sheet for Android Interviews
Stream summarizer and cardinality estimator.
This project aims to provide a working page flip implementation for usage in ListView.
JVM Profiler Sending Metrics to Kafka, Console Output or Custom Reporter
SwipeBack is an android library that can finish a activity by using gesture.
an open source solution to application performance monitoring for java server applications
Provides support to increase developer productivity in Java when using MongoDB. Uses familiar Spring concepts such as a template classes for core API usage and lightweight repository style data access.
MongoDB object-document mapper in Java based on https://github.com/mongodb/mongo-java-driver
FST: fast java serialization drop in-replacement
An android library which provides a compact calendar view much like the one used in google calenders.
A Java to JavaScript transpiler.
A customizable and easy to use BottomBar navigation view with sleek animations, with support for ViewPager, ViewPager2, NavController, and badges.
Layout and functional testing framework for websites
Checklist for code reviews
An advanced, but easy to use, platform for writing functional applications in Java 8.
A functional reactive framework for managing state evolution and side-effects.
Writing SQL using Java syntax
FlexyPool adds metrics and failover strategies to a given Connection Pool, allowing it to resize on demand.
Apache Geb: Very Groovy Browser Automation
A scope tree based Dependency Injection (DI) library for Java / Kotlin / Android.
Distributed Stream and Batch Processing
High performance JVM JSON library
AWS SDK for Android. For more information, see our web site:
Java Collections till the last breadcrumb of memory and performance
Esper Complex Event Processing, Streaming SQL and Event Series Analysis
Provide support to increase developer productivity in Java when using Neo4j. Uses familiar Spring concepts such as a template classes for core API usage and lightweight repository style data access.
Java API for Natural Language Generation. Originally developed by Ehud Reiter at the University of Aberdeen’s Department of Computing Science and co-founder of Arria NLG. This git repo is the official SimpleNLG version.
binary serialization format
Java fake data generator
JSON query and transformation language
Binary Artifact Management Tool
iWF is a Workflow-As-Code microservice orchestration platform offering an orchestration coding framework and service for building resilient, fault-tolerant, scalable long-running processes
Create your Java crypto trading bot in minutes. Our Spring boot starter takes care of exchange connections, accounts, orders, trades, and positions so you can focus on building your strategies.
A beautiful material calendar with endless scroll, range selection and a lot more!
🔐 An SSL library for configuring http client or server. Rich with features such as hot reloading ssl and trusting additional certificates during runtime, combining multiple keystores, loading pem files and os/jdk certificates, logging certificate information during ssl handshake, bypassing ssl configuration from other libraries and more
Automon combines the power of AOP (AspectJ) with monitoring or logging tools you already use to declaratively trace and monitor your Java code, the JDK, and 3rd party libraries.
A thin Java wrapper to access the Steamworks API
java port of Underscore.js
Identifies and prioritizes Class and Package Cycles and Anti-pattens in Java & Kotlin codebases you should refactor first.
A curated list of resources related to the Java annotation processing API (JSR 269)
The Railcraft Mod for Minecraft, source and development.
DAO oriented database mapping framework for Java
Cloud Foundry buildpack for running Java applications
A vector drawing editor for LaTeX (JavaFX).
Language-Natural Persistence Layer for Java
An extensible Java framework for building event-driven applications that break up XML and non-XML data into chunks for data integration