401.sashirestela / simple-openai
A Java library to use the OpenAI Api in the simplest possible way.
Ranked by Attention Score: stars gained over the last 90 complete days
401–500 of 673 by Attention Score · Aug 5, 2026 – Nov 2, 2026 (UTC)
A Java library to use the OpenAI Api in the simplest possible way.
Provides tracing abstractions over tracers and tracing system reporters.
No description provided by the repository host.
Augmented text display system for libGDX, based on typing-label
Error Prone extensions: extra bug checkers and a large battery of Refaster rules.
Android and Java bytecode viewer
Android Library to rapidly develop attractive and insightful charts in android applications.
OpenAPI (f.k.a Swagger) Specification code generator. Supports C#, PowerShell, Go, Java, Node.js, TypeScript, Python
A fast, lightweight and more productive microservices framework
Implementation of various string similarity and distance algorithms: Levenshtein, Jaro-winkler, n-Gram, Q-Gram, Jaccard index, Longest Common Subsequence edit distance, cosine similarity ...
Cheat Sheet for Android Interviews
Horizon - Simple visual equaliser for Android
RabbitMQ Java client
A Java library for capturing, crafting, and sending packets.
Gradle/Maven plugin to package Java applications as native Windows, MacOS, or Linux executables and create installers for them.
High performance JVM JSON library
ADAM is a genomics analysis platform with specialized file formats built using Apache Avro, Apache Spark, and Apache Parquet. Apache 2 licensed.
zerocode-tdd is a community-developed, free, open-source, outcome-driven automated testing framework for Data Pipelines, ETL, REST API, Kafka(Data Streams), Databases and Load scenarios. all defined in simple JSON or YAML — with zero coding.
A Java library for parsing and building iCalendar data models
Apache Wicket - Component-based Java web framework
An extensible Java framework for building event-driven applications that break up XML and non-XML data into chunks for data integration
Computer Graphics and Gaming API (Vulkan, OpenGL, GLFW, STB, ...) bindings for Java using Java 22 FFM APIs
The Spring Boot of Selenium — conventions and sensible defaults for Java test automation, without hiding WebDriver.
Build powerful pipelines in any programming language.
Side menu with some categories to choose.
Speedment is a Stream ORM Java Toolkit and Runtime
Distributed Big Data Orchestration Service
JPHP - an implementation of PHP on Java VM
Layout and functional testing framework for websites
Checklist for code reviews
📄The reliable, generic, fast and flexible logging framework for Android
Bloop is a build server and CLI tool to compile, test and run Scala fast from any editor or build tool.
Zero-allocation hashing for Java
Fast, lightweight, and RFC 4180 compliant CSV library for Java. Zero dependencies, ~90 KiB. Trusted by Apache NiFi, JUnit, and Neo4j.
Binary Artifact Management Tool
Mirror of Apache Openmeetings
🔐 An SSL library for configuring http client or server. Rich with features such as hot reloading ssl and trusting additional certificates during runtime, combining multiple keystores, loading pem files and os/jdk certificates, logging certificate information during ssl handshake, bypassing ssl configuration from other libraries and more
DAO oriented database mapping framework for Java
The open-source Java obfuscation tool working with Ant and Gradle by yWorks - the diagramming experts
Published on Maven Central Java Library that compares 2 images with the same sizes and shows the differences visually by drawing rectangles. Some parts of the image can be excluded from the comparison. Can be used for automation QA tests.
Detect uses of legacy Java APIs
Modern Reactive CQRS Architecture Microservice development framework based on DDD and EventSourcing | 基于 DDD & EventSourcing 的现代响应式 CQRS 架构微服务开发框架
A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).
Declarative UI for Java
Java library that provides an interface to directly interact with Valve's Steam servers.
TypeDB Drivers for Rust, Python, Java, Node.js, C, C++, and C#.
Anahata ASI - Artificial Super Intelligence - Cross-Platform, Modular, Enterprise Ready, Open Source, Pure Java, AGI and ASI Containers. Context Window Garbage Collector, Stateful Toolkits, Flight Recorder. Autonomous Observable Auditable JVM Agent with JIT java code execution. Anahata ASI SDK, Anahata ASI Desktop, Anahata ASI Studio - NetBeans.
Learning RxJava for Android by example
BinNavi is a binary analysis IDE that allows to inspect, navigate, edit and annotate control flow graphs and call graphs of disassembled code.
Android library for multiple snapping of RecyclerView
A Java to JavaScript transpiler.
Minimal UI library for Android inspired by React
Make Slack and Facebook Bots in Java.
Fast Clojure Matrix Library
AWS SDK for Android. For more information, see our web site:
The Stack Overflow clone for your team (self-hosted or hosted)
Esper Complex Event Processing, Streaming SQL and Event Series Analysis
Provide support to increase developer productivity in Java when using Neo4j. Uses familiar Spring concepts such as a template classes for core API usage and lightweight repository style data access.
A schema-first tool for graphql-java inspired by graphql-tools for JS
Zircon is an extensible and user-friendly, multiplatform tile engine.
Create your Java crypto trading bot in minutes. Our Spring boot starter takes care of exchange connections, accounts, orders, trades, and positions so you can focus on building your strategies.
The Railcraft Mod for Minecraft, source and development.
The New Official Aparapi: a framework for executing native Java and Scala code on the GPU.
A vector drawing editor for LaTeX (JavaFX).
Android Library to make it easy to create an Code editor or IDE that support any languages and themes, with auto complete, auto indenting, snippets and more features
Chrome DevTools java client.
A lightweight, simple FTP server. Pure Java, no dependencies.
Deploy, execute, manage process-based applications made with Bonita studio or through Engine APIs
The Frank!Framework is an easy-to-use, stateless integration framework which allows (transactional) messages to be modified and exchanged between different systems.
Nuts Java Package Manager
Chemical 2D structure editor application/applet based on the Chemistry Development Kit
Make Java source layout deterministic: reorder class members safely, keep accessors together, format java-source, and enforce style in CI.
A code-first BDD testing framework for Kotlin & Java.
Ultra-lightweight Java DI framework with JSR-330 support, fast classpath scanning, and zero boilerplate. Minimal alternative to Spring/Guice.
The open-source safety layer for AI agents — block unsafe tool calls, require approval, enforce budgets, audit, replay.
Material Design implementation for Android 4.0+. Shadows, ripples, vectors, fonts, animations, widgets, rounded corners and more.
Learn, design or document codebase by putting breadcrumbs in source code. Live updates, multi-language support and more.
Maven plugin for running and creating Docker images
Elixir plugin for JetBrain's IntelliJ Platform (including Rubymine)
JVM Profiler Sending Metrics to Kafka, Console Output or Custom Reporter
Life is too short to google for dependencies and versions
Dex : The Data Explorer -- A data visualization tool written in Java/Groovy/JavaFX capable of powerful ETL and publishing web visualizations.
A functional reactive framework for managing state evolution and side-effects.
Writing SQL using Java syntax
Apache Geb: Very Groovy Browser Automation
Build a GraphQL service in seconds
Java API for Natural Language Generation. Originally developed by Ehud Reiter at the University of Aberdeen’s Department of Computing Science and co-founder of Arria NLG. This git repo is the official SimpleNLG version.
Object-Oriented Java primitives, as an alternative to Google Guava and Apache Commons
Java fake data generator
Client library for Amazon Kinesis
A scientific charting library focused on performance optimised real-time data visualisation at 25 Hz update rates for data sets with a few 10 thousand up to 5 million data points.
java port of Underscore.js
Advanced date, time and interval library for Java with sun/moon-astronomy and calendars like Chinese, Coptic, Ethiopian, French Republican, Hebrew, Hijri, Historic Christian, Indian National, Japanese, Julian, Korean, Minguo, Persian, Thai, Vietnamese
MQTT CLI is a useful command line interface for connecting various MQTT clients supporting MQTT 5.0 and 3.1.1
Neo4j Bolt driver for Java
The core OneBusAway application suite.
Clojure library for CUDA development
Open eHealth Integration Platform
Official Neo4j JDBC Driver