1.toon-format / toon
🎒 Token-Oriented Object Notation (TOON) – compact, human-readable serialization of JSON data for LLM prompts. TypeScript SDK, CLI, benchmarks.
Ranked by Attention Score: stars gained over the last 180 complete days
54 repositories by Attention Score · May 7, 2026 – Nov 2, 2026 (UTC)
🎒 Token-Oriented Object Notation (TOON) – compact, human-readable serialization of JSON data for LLM prompts. TypeScript SDK, CLI, benchmarks.
Protocol Buffers - Google's data interchange format
FlatBuffers: Memory Efficient Serialization Library
Extremely fast, in memory, serialization, reflection, and RPC library for C++. JSON, BEVE, BSON, CBOR, CSV, JSONB, MessagePack, TOML, YAML, EETF
A blazingly fast multi-language serialization framework for idiomatic domain objects, schema IDL, and cross-language data exchange.
Fast, correct Python JSON library supporting dataclasses, datetimes, and numpy
Static reflection for enums (to string, from string, iteration) for modern C++, work with any enum type without any macro or boilerplate code
The fastest JSON library in C
Extremely Fast MessagePack Serializer for C#(.NET, .NET Core, Unity, Xamarin). / msgpack.org[C#]
A C++11 library for serialization
YamlDotNet is a .NET library for YAML
Nameof operator for modern C++, simply obtain the name of a variable, type, function, macro, and enum
Java binary serialization and cloning: fast, efficient, automatic
CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.
HTML parsing/serialization toolset for Node.js. WHATWG HTML Living Standard (aka HTML5)-compliant.
Cista is a simple, high-performance, zero-copy C++ serialization & reflection library.
A lightweight C++20 serialization and RPC library
Safely pass trusted data to untrusted environments and back.
A lightweight library for converting complex objects to and from simple Python datatypes.
C++ Reflection Library
Rapid YAML - a library to parse and emit YAML, and do it fast.
FASTJSON 2.0.x has been released, faster and more secure, recommend you upgrade.
💡Extremely fast enterprise server framework, can be used in RPC, game server, web server.
Faster enum reflection for C++17 since I don't want to wait for C++26 reflection.
Your binary serialization library
A high-performance 100% compatible drop-in replacement of "encoding/json"
universal serialization engine
Cross-browser storage for all use cases, used across the web.
Yet Another Serialization
The official Firely .NET SDK for HL7 FHIR
🕵️ Tool to reverse-engineer Protocol Buffers with unknown definition
Fast Binary Encoding is ultra fast and universal serialization solution for C++, C#, Go, Java, JavaScript, Kotlin, Python, Ruby, Swift
A correct and safe(er) JSON RFC 8259 reader/writer with sane defaults.
json_struct is a single header only C++ library for parsing JSON directly to C++ structs and vice versa
Quick serialization of R objects
✨ Next-gen C++ JSON Serialization Engine | Zero Dependency | Header-Only | Unleash JSON Potential
A few classes for extremely fast json parsing/serializing in modern C++. Possibly the fastest json parser in C++. Possibly the fastest json serializer in C++.
MUS format serializer for Go
Getting serious about Vulkan development with this modern C++ framework, battle-tested in rapid prototyping, research, and teaching. Includes support for real-time ray tracing (RTX), serialization, and meshlets.
Fast, idiomatic C# implementation of Flatbuffers
Header-only, lightweight C++ library for binary streaming & serialization. Network data handling made easy peasy!
Scala macros for compile-time generation of safe and ultra-fast JSON codecs + circe booster
Single header YAML 1.0 C++11 serializer/deserializer.
FST: fast java serialization drop in-replacement
binary serialization format
Language-Natural Persistence Layer for Java
Protocol Puffers: A little, highly templated, and protobuf-compatible serialization/deserialization header-only library written in C++20
Multi-format serialization library for C++17: JSON/JSONC, CSV and MsgPack (dependency-free), plus XML and YAML
Polymorphic serialization for .NET
Hprose is a cross-language RPC. This project is Hprose 2.0 for Delphi and FreePascal
An Fast, Intuitive and Type-Safe C++ Enumeration Support Library
OpenAPI based binary serialization
Reflection and serialization library. Supports json, yaml, and binary. Uses libClang AST for code generation.
A data serialization/contract library for common lisp