1.toon-format / toon
🎒 Token-Oriented Object Notation (TOON) – compact, human-readable serialization of JSON data for LLM prompts. TypeScript SDK, CLI, benchmarks.
Ranked by Attention Score: stars gained over the last 30 complete days
41 repositories by Attention Score · Oct 4, 2026 – Nov 2, 2026 (UTC)
🎒 Token-Oriented Object Notation (TOON) – compact, human-readable serialization of JSON data for LLM prompts. TypeScript SDK, CLI, benchmarks.
Protocol Buffers - Google's data interchange format
FlatBuffers: Memory Efficient Serialization Library
Extremely fast, in memory, serialization, reflection, and RPC library for C++. JSON, BEVE, BSON, CBOR, CSV, JSONB, MessagePack, TOML, YAML, EETF
Fast, correct Python JSON library supporting dataclasses, datetimes, and numpy
The fastest JSON library in C
Static reflection for enums (to string, from string, iteration) for modern C++, work with any enum type without any macro or boilerplate code
Extremely Fast MessagePack Serializer for C#(.NET, .NET Core, Unity, Xamarin). / msgpack.org[C#]
A blazingly fast multi-language serialization framework for idiomatic domain objects, schema IDL, and cross-language data exchange.
YamlDotNet is a .NET library for YAML
CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.
A C++11 library for serialization
A lightweight library for converting complex objects to and from simple Python datatypes.
Cross-browser storage for all use cases, used across the web.
Java binary serialization and cloning: fast, efficient, automatic
HTML parsing/serialization toolset for Node.js. WHATWG HTML Living Standard (aka HTML5)-compliant.
C++ Reflection Library
Nameof operator for modern C++, simply obtain the name of a variable, type, function, macro, and enum
Safely pass trusted data to untrusted environments and back.
Cista is a simple, high-performance, zero-copy C++ serialization & reflection library.
A lightweight C++20 serialization and RPC library
Rapid YAML - a library to parse and emit YAML, and do it fast.
🕵️ Tool to reverse-engineer Protocol Buffers with unknown definition
The official Firely .NET SDK for HL7 FHIR
Quick serialization of R objects
Faster enum reflection for C++17 since I don't want to wait for C++26 reflection.
💡Extremely fast enterprise server framework, can be used in RPC, game server, web server.
Your binary serialization library
Fast Binary Encoding is ultra fast and universal serialization solution for C++, C#, Go, Java, JavaScript, Kotlin, Python, Ruby, Swift
json_struct is a single header only C++ library for parsing JSON directly to C++ structs and vice versa
Getting serious about Vulkan development with this modern C++ framework, battle-tested in rapid prototyping, research, and teaching. Includes support for real-time ray tracing (RTX), serialization, and meshlets.
Protocol Puffers: A little, highly templated, and protobuf-compatible serialization/deserialization header-only library written in C++20
A high-performance 100% compatible drop-in replacement of "encoding/json"
FST: fast java serialization drop in-replacement
binary serialization format
Fast, idiomatic C# implementation of Flatbuffers
Fast, convenient JSON serialization and parsing in C++
Language-Natural Persistence Layer for Java
A correct and safe(er) JSON RFC 8259 reader/writer with sane defaults.
A few classes for extremely fast json parsing/serializing in modern C++. Possibly the fastest json parser in C++. Possibly the fastest json serializer in C++.
A data serialization/contract library for common lisp