JSON for Modern C++
- json
- json-pointer
- json-patch
- cbor
47,133 repositories indexed
1–6 of 6 · Most stars
JSON for Modern C++
C/C++ WebRTC network library featuring Data Channels, Media Transport, and WebSockets
Version 1.2. This is the source code to STUNTMAN - an open source STUN server and client code by john selbie. Compliant with the latest RFCs including 5389, 5769, and 5780. Also includes backwards compatibility for RFC 3489. Compiles on Linux, MacOS, BSD, Solaris, and Win32 with Cygwin. Windows binaries avaialble from www.stunprotocol.org.
A comprehensive test suite for RFC 8259 compliant JSON parsers
Header-only C++11 library to encode/decode base64, base64url, base32, base32hex and hex (a.k.a. base16) as specified in RFC 4648, plus Crockford's base32. MIT licensed with consistent, flexible API.
Modern, Async, Non-Blocking, zero-dependency C++20 RFC 6455 Compliant WebSocket client & server, cross-platform, single-header, WS/WSS support.