Let's Encrypt/ACME client and library written in Go
- letsencrypt
- acme
- certificate
- tls
47,133 repositories indexed
1–20 of 20 · Most stars
Let's Encrypt/ACME client and library written in Go
Go package for UUIDs based on RFC 4122 and DCE 1.1: Authentication and Security Services.
simple, fast, reliable websocket server & client, supports running over tcp/kcp/unix domain socket. keywords: ws, proxy, chat, go, golang...
📧 Easy to use, yet comprehensive library for sending mails with Go
CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.
An HTTP cache system, RFC compliant, compatible with @tyktechnologies, @traefik, @caddyserver, @go-chi, @bnkamalesh, @beego, @devfeel, @labstack, @gofiber, @go-goyave, @go-kratos, @gin-gonic, @roadrunner-server, @zalando, @zeromicro, @nginx and @apache
A go implementation of the STUN client (RFC 3489 and RFC 5389)
Compute the diff between two JSON documents as a series of JSON Patch (RFC6902) operations
Package arp implements the ARP protocol, as described in RFC 826. MIT Licensed.
Diameter stack and Base Protocol (RFC 6733) for the Go programming language
CoAP Client/Server implementing RFC 7252 for the Go Language
Brotli compression library for Go (RFC 7932), pure Go, no cgo, encoder + decoder, highly optimized
A Memento Aggregator CLI and Server in Go
Package dhcp6 implements a DHCPv6 server, as described in RFC 3315. MIT Licensed.
Time-Based One-Time Password (TOTP) and HMAC-Based One-Time Password (HOTP) library for Go.
Problem json implementation (https://tools.ietf.org/html/rfc7807) package for go
Next-generation HTTP router for Go 1.27+ with type-safe handlers, RFC 9457 errors, and built-in OpenAPI generation. Minimal dependencies, blazing performance.
A tiny, zero-dependency Go library that validates UUIDs against standard RFC 4122 formatting, converts UUIDv7() into timestamps by ensuring accuracy and light compute.
NAT type diagnosis CLI. Tells you why WebRTC/P2P/VPN connections fail and whether TURN is required.
RFC downloader and archiver that stores RFCs on IPFS, and indexes them against Lens